Julius Caesar (Columbia Games)

I have played many times with one friend and the Julius Caesar module works perfectly.
I can play other vassal games (C&C Napoleon) with my new friend, however Julius Caesar doesn’t want to work for us.

When I create a game, my opponent isn’t able to select a side and they automatically become the same side that I select.
We see both Green and red blocks however if i switch sides, so does he automatically. If i or he rolls dice, it says “Caesar rolls dice”. Same for if I or he moves a block.
We have also tried it with him hosting the game, same effect.
Vassal seems to sync OK when we start.

He initially was on a MAC but has also tried a PC to the same effect.
We have the same, latest version of JAVA, Vassal and the Mod.
I am on a PC Windows 10.

Any idea what is causing this. Is this a known issue?
Would appreciate some help on this.

Many Thanks

You are both using the same password. The password is vassal’s way of linking you to a particular side. Start vassal and choose preferences, then personal. Enter a password. It is not a bank account, so security is not an issue. It just needs to be different. I use my telephone number for mine.