linux beta5 does not do anything anymore

Sorry for being such a pain…

xubuntu 8.10 64-bit
Sun jdk 6u10 64-bit

I re-loaded the whole shebang from the ground up (I mean it was only a day old so no biggie) because of an issue I was having with the version of eclipse the package manager tried to stick me with the first time.

Now when I execute (from the beta5 zip file) nothing happens. It worked before with the slews of javas I loaded trying to get everything else up and running. So the script itself is obviously fine just needs some tweaking maybe?

The jdk is sitting in home/johnmurphy/jdk1.6.0_10/bin/java
I had to add a -vm line in eclipse.ini to get eclipse to see it
-vm home/johnmurphy/jdk1.6.0_10/bin/java

This is the only java on my system at the moment.

Do I need to do something like this for VASSAL and if so where do I do it?
Is it in the sh script itself?

Thus spake “IrishBouzouki”:

I don’t understand why people thing they’re being a pain when they report
problems. The problems are there, it’s not like they’re causing the

This is why it isn’t working. The script assumes that java will be on your
path, and I’m guessing that you didn’t add /home/johnmurphy/jdk1.6.0_10/bin
to your path.

Edit to include the location of your java binary. Change the line

cd dirname "$0" && java -classpath lib/Vengine.jar VASSAL.launch.ModuleManager “$@”


cd dirname "$0" && /home/johnmurphy/jdk1.6.0_10/bin/java -classpath lib/Vengine.jar VASSAL.launch.ModuleManager “$@”


Messages mailing list …

Post generated using Mail2Forum (

Thanks Joel.

No. I am not really sure why the sun installer did not do this. But the install proces was a little complicated and had to be executed in a terminal window etc. There may be a step that was missing from the instructions on the Sun site.
I will look up how to add stuff to “my path” and see if that provides a more general solution down the road. Meanwhile…

…I will give this a try. Thanks.

Oddly, this did not work. So I opened a terminal window and tried to mess around a bit with commanding directly from the terminal. Entering the following, from the Vassal directory, did start Vassal successfully.

/home/johnmurphy/jdk1.6.0_10/bin/java -classpath lib/Vengine.jar VASSAL.launch.ModuleManager

However, editing the .sh to have only this did not work - maybe without the directory info it does not know the directory to start from although /home should point you to the same spot anyhow? Just to check I tried…

/home/johnmurphy/jdk1.6.0_10/bin/java -classpath /home/johnmurphy/VASSAL-3.1.0-beta5/lib/Vengine.jar VASSAL.launch.ModuleManager

…in the .sh and that did not work either.
For one last thing, I tried…

cd /home/johnmurphy/VASSAL-3.1.0-beta5 && /home/johnmurphy/jdk1.6.0_10/bin/java -classpath /home/johnmurphy/VASSAL-3.1.0-beta5/lib/Vengine.jar VASSAL.launch.ModuleManager

…and that did not work either.
I think need to come back to this after remedial linux training.

Thus spake “IrishBouzouki”:

This is because the Sun installer doesn’t (and can’t) know where your path
is being set.

What’s the reason that you’re installing a JDK in your home directory? Is
there something wrong with the JDK provided by XUbuntu? There ought to be
an OpenJDK package which you could install which should work and take care
of the path issues for you.

Unless you have a compelling reason to the contrary, you should install
software through the package manager on a package-managed system. It will
save you a lot of maintenance burden and pain in the long run.


Messages mailing list …

Post generated using Mail2Forum (

Thus spake “IrishBouzouki”:

What did it do? What did you see? Please tell us what output there was,
if any.

Was there any output in your terminal when you did this? (This kind of
information is what’s needed in order to solve such problems.)


Messages mailing list …

Post generated using Mail2Forum (

On Wed, November 19, 2008 2:05 pm, Joel Uckelman wrote:

Ubuntu seems to be in a bit of a state with Java packages at the moment.

Sun JDK mostly works, but sometimes has problems creating dialog boxes
(they’re created empty, or of insane sizes) - from digging this seems to
be an interaction with compiz.

OpenJDK doesn’t have the window problem, but severely mangles fonts in
some apps (not, by the look of things, VASSAL).

IIRC, the whole point of XUbuntu is that it’s an older, light-weight WM,
so the Sun JDK should be fine.

But I’d absolutely second the recommendation to use package management
unless you’ve got a really good reason not to :slight_smile:


Messages mailing list …

Post generated using Mail2Forum (

xubuntu 8.10 64-bit does not ship with any java pre-installed that I know of, any Java you add you have to do after installing the OS, or so it seems. I may be mistaken but that is my impression. I am happy to be educated although this is not the site for that, but to elucidate further…

when you go to add java (or several other apps like eclipse) thru synaptic (the xubuntu package manager) you often get a much outdated version which is incredibly frustrating (for instance it was sticking me with early-6 javas vice 6u10 and with eclipse 3.2 vice 3.4, and the version of eclipse 3.2 it had just broke period trying to load up subversion). the entire interface for synaptic, while easy to use, does not seem to find the most up to date or reliable version of anything that i needed. so I am avoiding it like the plague and instead going and picking exactly the version and file I want under my total control, which has a downside because when it comes to actually setting it up on the machine I am like a windows fish out of water. I had to go the manual tarball download route for both sun jdk 64 bit and for the latest eclipse to match. being a linux idiot I ran into root user issues (ubuntu being a bit weird about that) trying to put java in /local/usr so I took my /home/johnmurphy as the next best thing as I could do it without having to invoke any root user priviledges. I am thinking this was not the brightest thing I have ever done but I managed to make everything work irregardless… except the vassal sh file that is.

I really prefer not to install 5 or 10 different java packages. I have one, it is the most bleeding-edge recent, I prefer that one to work. And I know Vassal does work under it at least to some point because I can get it to do that much from the terminal command line, there is just an issue with me being an idiot and not being able to get the sh file to fire it off properly from the file manager gui.

when I say “does not work” or “does not do anything” I mean just that… I double-click (or alternatively right-click and select ‘execute’) the icon in the gui and literally nothing seems to happen. which is why I tried the command line interface directly so I could see something about what is going on. when I say it worked from the terminal window I mean the vassal module launcher screen came up which I presume means the command managed to start the program running. and I should add that it was working on my first attempt where I was using some oddbal old jre installed by synaptic. even loaded up a module and moved some pieces around on that try before I scrubbed it and re-formatted the entire os load.

I will work on this some more tonite, but I am severely handicapped by my lack of familiarity with the OS and if I am not making much progress it will have to wait a while and I can go back to my vista system.

Thus spake “IrishBouzouki”:

I think that package you want does not have “java” in its name in Ubuntu.
I believe it’s called “openjdk-6-jdk”. Try seeing if you can use your
package manager to install a package with that name.


Messages mailing list …

Post generated using Mail2Forum (

never mind… I just can not type… I left off one of the folders in the pathname so I thought I was entering the correct path to java but I was not.

by the way, there ia useful hidden file called .xsession-errors which shows all the dumb things the command interpreter tried and failed to do while you were blissfully staring at the GUI in your current login session. looking into that file I noticed the java was not being found and also noticed the path where it was trying to find had a typo (my typo from trying to hard-wire the path).

thanks for your patience folks.