Linux openjdk 11 issue

Vassal 3.6.10 runs fine on my ubuntu 22.04. Vassal 3.6.12 reports java version 11 not available. I have been running with the openjdk version of java 11.0.18. … not sure why 3.6.12 is complaining nor how to fix it?

Thanks for any suggestions

What’s the result with Vassal 3.6.14, the current version? (If there’s an error, please state the exact error message.)

3.16.14 worked without error. Thanks!

I have the same problem, when I try to run version 3.6.15 in Slackware, with openjdk 11 (version 11.0.18). When I do, the following error message appears:

Error: /usr/lib64/java/bin/java is too old to run this version of Vassal. Please use Java 11 or later.

Now, I have three versions of java in the usr/lib64/ path (java, jdk8u345_b01 and jdk11, which I don’t want to delete), so I imagine the problem is that it keeps choosing the “wrong” java version…

I guess I need to change the path in the script to point it to the “correct” version (that is usr/lib64/jdk11/java/bin/java), right? But how, exactly? I’m a newbie with the script issues in Slack…

Thaks for any help.



What is the output from running java --version?


It’s this:

bash-5.1$ java --version
openjdk 11.0.18 2023-01-17
OpenJDK Runtime Environment (build 11.0.18+10)
OpenJDK 64-Bit Server VM (build 11.0.18+10, mixed mode)

What is the directory where you’ve installed Vassal? (Please give the complete path.)

Oops…I actually seem not having installed Vassal… :blush: Suppose must do in the “hard” way, with the configure-make-make install commands, right? There seems not to exist a compiled package for Slackware…There exists a Slackbuilds script but it’s for an older version (3.5) and requires the installation of another (!) java version (zulu-openjdk17)…

This is what I did:

  • Unpacked the tarball

  • clicked in file in the unpacked directory twice, but only a script came up.

  • then, I tried to use the command shell to open the file instead.

  • when I did that, the program abated an the error message I sent appeared.

That never happened to me with the old version(s) I had. When I run the command in the shell, the program run with no issues…

None of this answers my question. I just want to know the directory where you unpacked the tarball.

Ah, sorry, didn’t get it…It was

/home/Pessoal/Miscelanea/Vassal/Vassal\ Program

That’s what I thought was happening. You’ve installed to a path with a space in it.

This thread deals with the same bug. We’ve fixed it in 3.7.0-beta2; alternatively, if you don’t want to install 3.7.0-beta2, you can edit the you have by changing this line



INSTALL_DIR=$(dirname "${EXEC_PATH}")

I tried your fix and did not work…Also, I downloaded the tarball for the directory Desktop (home/tiago/Desktop, untared the tarball and tried to launch form there, but it didn’t work, also…

Change this line near the top of from

set -e


set -ex

and paste here the output when you run

It worked! Thanks.
I guess when v7.0 is fully operational, I will change the name of the folder to eliminate the space (a Salck newbie error, I know…).