MAC OS 11.7.4 update won't let me access Vassal

Just updated my MAC from OS BIG SUR (11,7,3) to 11,7.4 this morning. Last night was playing on Vassal version 3.6.11 everything was fine. This morning after MAC OS update it won’t let me access Vassal. Says I don’t have permission. Checked the application and folder and it says I do have read, write permission? Downloaded Vassal 3.6.12 to see if that fixed it. Same result. Anyone have any ideas what’s wrong? Help.

Can you be more specific? What says you don’t have permission? What’s the exact message? Could you provide a screenshot?

I’d check your Gatekeeper settings to see if the update changed them. Apple menu in top left, Preferences → Security & Privacy

A fast workaround for Gatekeeper is to find the VASSAL application, hold down the Option key on your keyboard, and right-click the application and choose “Open” while keeping the Option key pressed.


Note I have changed the permissions on the application to be read/write for Admin and everyone