MACOS 10.14.6 - will not open VASSAL DMG FILES

I have two iMacs both at macOS 10.14.6

On one of them, I downloaded the latest version of the VASSAL ENGINE, intending to upgrade it from 3.2.12 - the other is already at 3.2.17 from a few months ago.

Anyway, when I launched the .dmg file I got an error…

VASSAL-3.2.17-macosx no mountable file systems (see image).

I checked on my other system and got the same error (even though that machine was already at 3.2.17)

I downloaded archived versions and ran those on both machines - same error.

I attempted to run other .dmg files from other providers - these all worked, without error.

My conclusion is that either the vassal engines .dmg files are corrupt or not compatible with this version of macos.

Can anyone else repeat my findings?

Clicked the green box on the homepage as per usual and it seems fine.

[attachment=0]Screen Shot 2019-09-29 at 9.05.11 AM.jpg[/attachment]

Just for reference, installed just fine on a clean 10.15 system (not an upgrade-in-place from 10.14.6), too.

I was able to install the latest version of VASSAL on my brand new iMac running Catalina, but I can’t get VASSAL to start.

The VASSAL icon will blink a few times in the dock and then go away.

The program won’t start at all.

I am running Java 13 and on macOS 10.15 Catalina.

When will VASSAL be able to work on this OS?

Thanks

Thus spake DonLazov:

I was able to install the latest version of VASSAL on my brand new iMac
running Catalina, but I can’t get VASSAL to start.

The VASSAL icon will blink a few times in the dock and then go away.

The program won’t start at all.

I am running Java 13 and on macOS 10.15 Catalina.

When will VASSAL be able to work on this OS?

Try the 3.3.0 test build I posted about a few minutes ago:

https://forum.vassalengine.org/t/test-builds-for-3-3-0/10056/1

3.2 isn’t compatible with anything later than Java 8.


J.