MacOS Graphics Issue (3.6.8)

OS: macOS Mojave v10.14.6
Memory: 16GB
Graphics: Intel Iris Pro 1536 MB
VASSAL: 3.6.8

I am seeing a graphical bug on an older MacBook Pro (Retina, 15-inch, Late 2013) with the latest 3.6.8 update. I am working on an unpublished module which was recently created in 3.6.7. After loading the module, scrolling the map, placing new counters, or moving counters causes large blocks of white, black, or segments of the map to appear on top of all other elements. Sometimes this effect is caused simply by clicking on the map or counters. I did not see any of these issues with the 3.6.7 version and I am not having any problems with the module on a new (2022 build) PC. Thank you very much for any ideas about what may be causing this.

Cheers! :slight_smile:


1 Like

I’ve tried replicating this on a couple of more recent Macs and can’t so far. Would you share a link to your module?

Configs tried:

iMac 27" (2020), 32Gb, Radeon Pro 5700 8GB, Ventura.
MacBook Pro (2016), 8Gb, Intel Iris Graphics 540 1536 MB, Monterey.

Vassal versions tried: v3.6.7 and v3.6.8
Modules tried: 2nd Fleet, Sixth Fleet, Flying Colors.

1 Like

Thanks Mark! I really appreciate the effort in trying to replicate this. Unfortunately the module is for an unannounced game that I can’t share publicly yet but I will try out some other modules and see if I can get the issue to repeat. It is an older Mac with an outdated OS so pretty low priority but it if turns out to be an easy fix I’d like to. Will report back. Cheers! :slight_smile:

1 Like

I know that when running on Windows, there is an option in VASSAL to “disable the Direct 3D pipeline”, or something along those lines, which can fix issues like this. Is there an equivalent option when running on a Mac?

1 Like

This sounds like a graphics driver problem. Do you see the option “Disable OpenGL FBOs” in the Preferences? If you do, tick that, close the module, and reopen it. Does that help?

1 Like

Hi all! Sorry for the delay. I wanted to report back that the suggestion to disable OpenGL FBOs has worked brilliantly and seems to have sorted things. I didn’t go for this option initially as I thought it would only affect newer Macs so thanks very much for the suggestion. In case it’s helpful I did open three other modules before trying that fix and have posted screenshots here:

The three modules that I tested were C&C Napoleonics, Maori Wars, and Red Storm and all three had similar issues. Red Storm takes the cake though as it was throwing up all sorts of scrambled text, images, etc. In all three cases the issues were tied to adding new counters, moving counters, interacting with cards, or opening new windows. I hope that this is helpful and if you have any questions or would like me look at it more closely let me know. Thanks again! :slight_smile:

1 Like

Just to be clear, the screenshots are from before you set “Disable OpenGL FBOs”? I.e., there’s nothing to solve now?

1 Like

Yep! That’s correct. These were all captured before trying that so all seems to be well once it’s enabled.