Marvel Heroes 1.2

I am releasing version 1.2 of the Marvel Heroes module today and I am opening up this new thread for support issues.

This issue adds a couple new features and solves many of the known bugs, please see the last post in the previous support thread.

The following is the list of remaining KNOWN ISSUES and BUGS (with a new numbering system for ease of reference) which will have to be addressed in a future release, if at all possible.

Please report any new bugs or malfunctions here. Please check for any updated version of this list further down this thread.

Known issues in version 1.2 (Vassal related and unsolvable with current engine):

  1. General slowness of response… keep in mind the module is doing a lot of behind the scenes actions for you… and Vassal was never really designed for this type of automation

  2. Resources and villain cards should not be movable at all (current Vassal limitiation): players are not supposed to drag them anywhere

  3. Multiple heroes in the same district do not stack properly (current Vassal limitation): players need to use UP/DOWN arrows to bring chosen hero to front

  4. Similarly, solved headlines and story cards don’t stack properly in team windows: used UP/DOWN arrows if you want to look at them

  5. Combat log in combat screen doesn’t roll well: sometimes, when hero/villain takes a KO and looks beaten, text overlaps instead of rolling

Known bugs in version 1.2

  1. The rare events of hero and villain simultaneously getting knocked off are not yet completely supported (Absorbing Man case only?) and the game will freeze

  2. Forced game ended has been reported following some story action which gave VP to a team, despite it being far from required winning level (solo play mode only?) → need more exhaustive reports, cannot reproduce!

  3. Elektra’s Ninja ability should be unstoppable by the likes of Sabretooth/Abomination (i.e. those villains should not be able to remove either the 1st and the 2nd KO when Elektra inflicts two KO’s at once via Ninja ability)

  4. The power ups/masterplans in the English/Spanish versions are mostly unreadable, some other cards are also hard to read

I don´t know if I am doing something wrong, but I can not find the combat token, so I can not roll the combat dice.

After hero and villain both select a combat power the combat tokens will be revealed. Then you right click on them to roll for attack, defense or outwit. But follow the prompts in the Combat screen, they tell you what’s you are supposed to do (Select power, Play abilities, Roll…).

Sorry, but they were not revealed. I have actually done the same as in the previous version, but the tokens did just not appear. I have tried solo and multiplayer.

Ahh… I see the problem, you must be using Vassal 3.1.18 (or 19 or 20), correct?

This appears to be another unexpected obscure side effect - the first one being the mysteriously masked headlines which forced immediate release of 1.2b - of the workaround I introduced to support independent language choice. For that to work Vassal 3.2.0 beta 3 is needed, but I still wanted to support the existing Vassal 3.1.18+ user base. I guess the workaround was too much of a dirty trick and problems are popping up.

I am sorry about it. While I think about what to do… could you please download and play with Vassal 3.2.0 beta 3, which you can find here.

Thanks for you report!

Yes, I am using 3.1.20.
Thank you for your help and for design such a good mod