Mouse Issue with Action Buttons at Zoom other than 100%

There seems to be an issue affecting Mouse click on Action Buttons at anything other than 100% Zoom; at least on a Mac with Retina screen.

The issue does not affect Trackpad.

To summarise: The mouse click works perfectly in the OS and even within Vassal - e.g. menus and to select pieces on screen and to bring up right-click menus. However, clicking on a action button is ignored, more often than not, unless the Zoom level is set to 100% in which case it works perfectly.


Thanks Mark,

I was unable to reproduce this on windows with a scaled UI setting, it may possible be a Mac only issue.

Could you please do an experiment and see if clicking away from the Action Button away from or towards the the top-left corner of the screen activates the Action Button? E.g. if the zoom is 50% does the Action Button activate if you click where the button would be at 100%?


Hi Brent - I tried that and couldn’t get any response away from the Action Button, at any zoom level.

From further testing, it seems persistence rather than location is what eventually gets the button to click; and by keeping in the same spot, I can get the button to more or less click repeatedly. Possibly small moves within the button make a difference but, if so, they are too small for me to test for. Generally speaking, if I move the mouse around the action button and then try clicking, it will be at least the second click before I get a response. By contrast, a click with the trackpad gets a response first time.

Possibly, the larger the button, the easier it is to get a response with the mouse.


Tried using the mouse on a MacBook, 13” Retina screen and it seems to work fine.
Could it be a difference between the machines or the screen sizes?

PS on the iMac, I am experiencing Java crashes in the vassal editor that I never had at all on the MacBook with same MacOS version. Error report points a finger at graphics hardware. So far, 5 crashes in 3 days.

Can you narrow down the range of versions where you have this problem? What’s the most recent version which doesn’t?

I tried V3.2.17 with the v3.42 C&C Napoleonics module - the action buttons there are used to select decks at the start of a game.

Sad to say, the mouse problem is evident there too.


I can’t reproduce this on Linux, neither with a scaled nor an unscaled UI, with 3.4.10.

To confirm: This is fixed in the current 3.5.4 development build, correct?

It’s been fixed for a while after your work in an earlier release; it was the same unreliable mouse click issue that someone else raised in another thread). I will test it in the current 3.5.4 build and update this thread.

Correct… tests out OK on VASSAL 3.5.4 snapshots cbfbe8a9e and cb4f850e2.

Tracking back through releases notes, I recall it was fixed in v3.5.1 by this one:

13742: Action Button trait should arm when pressed, fire on release