Multi-Action button in Vassal 3.5.8

I am in the process of reworking a Vassal module that I had built on a previous version. In that previous version, I had a Multi-Action button that executed two Global Key Commands–one to delete any markers that had a property of Color==“White” and one to flip any markers that had a property of Color==“Yellow” (in the physical game, white is the reverse side of the yellow counters).

It worked like a charm in the previous version. In the current build, the Color==“White” markers are being deleted correctly, however the Color==“Yellow” markers keep flipping back and forth when the button is clicked. It’s as if those markers are retaining the “Yellow” property even after they’ve been flipped to the “White” side, whereas this didn’t happen before.

I have compared my current version to the previous one and I am nearly certain that I have copied the same settings over. Has this functionality been changed in the more recent versions of Vassal?

How exactly are you “flipping” these markers? I can’t think of any command that would automatically change an unrelated property (Color) just because the marker was flipped…

I have the Global Key Command set to Ctrl+F to flip them.

In the previous version, it appears that when the markers were flipped from the yellow to the white side, it was evaluating their Color property as “White”.

What is the most recent version of VASSAL where your module worked as intended?

The older version is working as intended even when I run it in 3.5.8 and the module was created around the Fall of 2019. I didn’t note the version, but I would assume at that time we’re talking 3.4 or so?

When I try to recreate the functionality in a new module using 3.5.8, I can’t get it to do the same thing; it doesn’t seem to evaluate the flipped yellow markers as “White”, and in turn, keeps flipping the markers back and forth, over and over.

Is there another setting I’m forgetting about that Multi-Action buttons and Global key commands need to work? I’ve scoured the old module and I’ve copied every setting over so I’m not sure where to look next.

You still haven’t made it clear exactly what trait you’re using to flip the counters: is it a Mask, a Layer, or what? In any case, as I said before, I can’t think of any trait that would automatically change a separate property just because you flipped the piece (except, possibly, Replace with Other)…

Is the (old version of the) module available on the wiki so we can look at it?

The trait I’m using is the Marker trait within the piece prototype. It’s given a property name of Color and a value of White or Yellow as the case may be. Each unit status marker in the game is given a Color Trait like this based on the color of the piece.

I don’t have them on the wiki yet as they are still not finished, but I’ve zipped the two modules into my cloud drive:

If you have time to take a look, Assault_41_PT_0.2.vmod is the old one and Assault_41_Training.vmod is the new one.

To see what I am talking about, load a Solitaire scenario and drag a bunch of Unit State Markers to the map from the Units & Markers tab. Then click the End of Turn clean up button (one with red arrow and red X).

In each case, any white markers should be deleted and yellow markers should flip to their white side (subsequent clicks should then delete these white markers). Green and Red markers should remain unchanged.

I appreciate your help on this one.

Look at your piece definitions in the Game Piece Palette: in the working version, the yellow markers have Ctrl-F mapped to a Replace with Other trait; in the new version, it’s mapped to a Layer trait, so the Color marker is never getting changed.

3.4.0 was released in September 2020, 3.3.0 in June 2020. Autumn 2019 would still have been 3.2.17.

Oh man, am I dense. Thank you for looking at this for me. I must have looked at every setting except for the individual pieces.

Lesson learned…write better documentation for the current version.

Appreciate the help everyone. You guys are awesome.

Okay thank you. Looks like it wasn’t the Vassal version, just a different trait I was using that I didn’t remember. :laughing: