Name the module java app buttons

Not sure if this is a java or MacOS limitation but it would be nice if Vassal’s java application buttons could be named for their modules rather than left as the generic “java” name.

For clarity, I am talking about the buttons that the user can press to bring a minimised app back to the screen (on MacOS these buttons sit in the “Dock”, normally at the bottom of the screen). Mousing over the button brings up the app name.

The main Vassal app does name its own button, so perhaps the module buttons could also be named.

Here is the bit of the screen that I mean…

[attachment=0]mac dock example.jpg[/attachment]

Would you post an errorLog from a run where you’ve opened several modules at once? The module name is supposed to get to those icons via the -Xdock:name property when the Player is run.

Error log attached.

I had three different modules open, relating to C&C Napoleonics.


The command lines I see there are what I was expecting to see. What was the last version where this worked for you?

Just checked against v3.2.17 and it is the same there. I was sure it would be as I didn’t recall seeing this working any other way since I started using Vassal - so that is from v3.2.17 on the various versions of MacOS since 2018.

I think I know what’s wrong: -Xdock:name hasn’t worked since MacOS X 10.8.

There’s apparently no replacement for this functionality.