New bugs in 3.6.6 for SW:Armada module

Tried to move the SW: Armada module over to 3.6.6, which caused 2 new bugs, 1 of which is game-breaking:

  1. Deployment zone not working; this is an at-start stack of some white lines (layers) that are toggled with a GKC om the map. Curiously ONE of the layers (a white cross in the middle of the map) is visible, but none of the other lines are.
  2. When trying to move a ship (piece) on the map using the command to place the maneuver tool, the ship… vanishes, making the game unplayable…
    I’ve tried to check the release notes but can’t really see anything that explains this behavior.

This only applies to the module after being updated to 3.6.6 (from 3.6.5) with no other changes to the module than the update to new version.

What do you mean by “updated”? Updated how?

Opened it in 366 and saved it.

What are the exact steps for triggering each of the two problems?

  1. Setup area designation: open a new game, push the button that sends GKC. Instead of all the setup lines appearing on the map (layers) only the “cross” in the middle is displayed (also a layer).

  2. Drag a ship to table, try to place the maneuver tool (hotkey CTRL+Shift Left or Right arrow, alternatively CTRL+Shift + Alt Left or Right arrow). Instead of the maneuver tool appearing, the ship vanishes.

I can’t reproduce either problem.

I clicked the “6x3 setup area” and “3x3 setup area” buttons and got a white cross and some lines. If I zoom out more than 100%, the lines aren’t drawn.

I tried placing several ships and the maneuver tool appeared without the ship disappearing.

Curious. I will have to investigate further. Could be a few days until I have the opportunity.