No Counters in Afrika II

Hi all,

I’m using version 3.1.0 of VASSAL, but this problem was occuring with the Beta release as well:

All my modules are working fine, except for one (Afrika II). It’s not a problem with the Module, because I’ve had others download it from the site and it works fine on their computers. I’ve also had someone email me their working version of the module, and it hasn’t worked on my computer.

Their working versions are the same version as mine, and are the exact same file size.

Here’s what’s happening: I’m not getting any information for 98% of the counters in the game, they appear as black. When I go into Edit Module, I don’t see any palette information (images) for the counters that are missing. I do see the information for the 2% of counters that aren’t black in the game…

In the [Game Pieces Palette], there is no mention of any counters whatsoever, except for the four counters that are appearing in the game.

I just unzipped the module and the counter images are there - I’ve just lost all reference to them. (This is the extent of my VASSAL knowledge, btw)

All my other modules are fine, I can’t understand how Afrika II seems to be losing counter information, only on my computer, and not on others’.

Any thoughts?

One more thing to add - when I hang my mouse pointer over the black counter stacks, the box will expand and show the counters with their proper artwork!

So the counters are only showing black on the map.


The counters in this version of Afirka are not in the palette anymore, just the markers.

I would suggest bumping up your heap and using memory mapping for this module as having all the counters on board initially will increase the load.

Also, any logs used with a previous version of Afrika I am fairly certain are not compatible with the new version.


Hi Keith,

Memory must be the problem - just realized that when I zoom in I can see the counters, but not when I’m zoomed out.

I have 2 MB RAM, Max heap set to 1024, and “memory mapped files for large images” is also turned on.

Strange. It worked before.

Can you please try turning off the DirectX D3D graphics pipeline in the preferences and try again.


Messages mailing list …

Post generated using Mail2Forum (

Hi Brent,

DirectX pipeline is turned off, both in the general VASSAL preferences, and within Afrika II. No difference.

I just noticed that this laptop only has 1MB RAM ( I have a few computers, thought I had 2 MB in here as well). Might that make the difference? Should I turn down the Heap size from 1024?

It’s strange, though, because I had it working on this computer before.

Yes! You’ve allocated your entire system RAM for Java. That means you’re swapping out to disk.

Set the initial and maximum heap to 256 and 512, respectively.

Then turn on prefer memory-mapped images for large files.

  • Michael.

Post generated using Mail2Forum (

Still not working… thanks for the ideas, though, guys!

Jay, could you post a link to the module?

  • M.

2009/3/7 jay white < (>

Post generated using Mail2Forum (

Thus spake “jay white”:

The Afrika_II_v0.9.vmod (which I downloaded from the modules library) works
fine under VASSAL 3.1.0 on my Linux box, with a max heap of 512MB and
memory-mapped images turned off.

Let’s use these to start from, so we can narrow down the possible problems.
When you use these settings (remember to restart VASSAL after setting them)
what happens?


Messages mailing list …

Post generated using Mail2Forum (

Thanks for your patience in helping me figure this out, guys!

mkiefte, the module is at: … page=Files

uckelman: I’ve set Afrika II with the following settings now, and restarted it, with the same problem, which I will describe below.

OFF: Prefer memory-mapped files for large images?
OFF: High quality scaling?
OFF: Disable DirectX D3D pipeline?
JVM initial heap: 256
JVM Maximum heap: 512

I start up VASSAL and double-click Afrika II. The startup wizard opens, I select either a saved game or start a new game (and select a pre-made setup).

The Markers (counters) window opens up. Its counters are visible (I assume because they’re scaled up, everything seems to work when it’s scaled up to full size). All other windows open fine. The map window opens up, the map takes a few moments to load, and the counters are all there, but they’re all black. (See attached image).

If I zoom out, the counters stay black. But if I zoom in, I can see the counters just fine. Also, if I leave my mouse pointer over a stack, the stack opens and I can see the counters just fine (see attached image).

There are no error messages in the Afrika II controls window.

I figured out a way to make it work!

I simply turned on “High Quality Scaling”

Thanks for everyone’s help. Any reason why this wouldn’t work without High Quality Scaling on?

Thus spake “jay white”:

Thanks for the detailed account of the problem. I’m certain now that this
has nothing at all to do with running out of memory. My guess is that it’s
another weird Windows graphics pipeline bug, either in Java or your video

What version of Java are you using? (You can check this by going to Help >
Show Error Log in the Module Manager, and looking for a line which says
“Java version …”)

Are you using the most up-to-date version of your video drivers?


Messages mailing list …

Post generated using Mail2Forum (

Thus spake “jay white”:

With High Quality Scaling, the scaling is happening in software, in some
code I wrote. With that turned off, scaling is done either by Java or by
your video hardware. My guess is that your video hardware and Java are
not playing well together.

If you wouldn’t mind, I’d like to keep working on this with you, to see
if we can pin down exactly what the problem is. If you want to do this,
please do answer my question about your Java version and your video


Messages mailing list …

Post generated using Mail2Forum (


This means that disabling of the D3D pipeline is off, which means that the D3D pipeline is actually on. There are at least one known (and other potential) bugs when the D3D pipeline is turned ON on a Windows machine. Could you please try turning this option ON, and see if this affects this problem you have when the High-quality scaling option is turned OFF?


Messages mailing list …

Post generated using Mail2Forum (

Brent, I had Disable DirectX turned ON before, but it didn’t make a difference.

uckelman, I’d be happy to pin down the source of the problem with you. I’ll check to see if my video drivers are up to date and get back to you. I’m using Java version 1.6.0_11

Thus spake “jay white”:

  • Check on your video drivers and, if you update them, let us know if there’s
    any difference.

  • The current version of Java is 1.6.0_12, which has some Windows graphics
    fixes in it. It’s possible that the problem won’t happen with that version;
    after checking on your video drivers, try upgrading Java and check again.

  • If neither of those things eliminate the problem, then I have an idea of
    something else to try, but I’d like to know the results of these first.


Messages mailing list …

Post generated using Mail2Forum (

Just a quick update, I’m teaching a workshop using my laptop and a funky projector setup for the next week, so I don’t want to mess with my drivers or anything until I’m finished. But I -will- get back to you.