No Retreat - Problem with Cards

my friend and I have a problem with the cards playing No Retreat (NR, actual version 1.4.1).

When I start a game playing the Axis side, I can draw cards normally and can use the units without any problems.
Then it is the Russian`s turn and he can not draw any Russian cards!?
We have changed sides, synchronized again but always with the same result… only one side can draw cards.

When I start a solitaire game I can draw cards for both sides normally.

We played NR two months ago without any problems… this is strange!

We tried playing NR using Vassal 3.1.19 and 3.1.20 with the same (bad) result. Always only one side can draw cards.

My system:
Intel i7-2600K with 3,4 GHz
Win 7, 64 Bit, 16 GB
Geforce GTX 570

I had to change my secret name in Vassal manually some weeks ago because I had two different passwords
for the my Vassal name on two computers. So I could not continue a game (Breakout: Normandy) on my second computer.
I changed my secret name manually in the preferences and all worked fine.

My Secret Name for No Retreat is identical in:


So THIS can not be the problem… :question:

Playing NR using Vassal makes soooooo much fun. Hope you can help us to start another NR-game soon.

Thank you very much in advance…


Which version did you use 2 months ago when it worked?

When this problem occured with Vassal 3.1.19 yesterday, we also installed 3.1.20 with the same result. I used 3.1.19 two months ago.

…And module 1.4.1?

I use NR-Module 1.4.1 since many months.

I have no problem to play Breakout:Normandy but there are no cards in this game and it is not important which side you play. You can even change sides during the game using Vassal.

NR is different. Here you can play only one side and the cards of the other side are hidden.
If I play the Germans I can draw cards but my friend (Russian side) can not. If he plays the German he can draw cards and I can not.

Are you and your friend using the same password?

No, it is only an outside chance that we use the same password. Almost impossible.

Well, I deinstalled Vassal and manually all directories (C:\Users…\AppData\Roaming\VASSAL\Preferences\ and C:\Users…\VASSAL\Preferences). Then I installed Vassal (3.1.20) and Module NR-The Russian Front (1.4.1) again (latest versions).
Had to enter Players Name and Password when starting Vassal.

The result is the same when I tried to start a game with another person (not the same as yesterday). Only one player can draw cards.

Then I started my notebook (Vassal 3.1.19 and NR 1.4.1). I played NR some weeks ago using this notebook. But now it is the same result with another player. Only one person can draw cards.

So there is no problem with my computer because I have the same result on my notebook.


I’ve had a little play with the NR 1.4.1 module and could not reproduce your problems. Please try the following:

  1. Download and install a new copy of the module.

  2. Start a new scenario (Which scenario are you having problems with?)

  3. When you select your Side, what are the options in the Side selection list?

  4. Save this game and send to your opponent.

  5. When he loads the save game, what options does he get in the Side Selection list?


Well, I deinstalled Vassal from my notebook and from my pc (incl. preferences manually).
Then I downloaded Vassal 3.1.20 and installed it on my notebook and on my pc with different playernames and different passwords.

I tried to start an online game using my notebook and my pc. PC started with German side, notebook the Russian side.
Room was normally opened and I played some German moves on my pc. Could see the moves on my notebook, too.
Could draw German cards normally using my pc.

Then I tried to draw Russian cards using the notebook… NOT possible! :frowning:
I could not draw German cards on my notebook, too (which is normal).

Then I started a pbem with the pc.
I started the campaign scenario (haven`t played anything else before).

I could choose following sides: Visitor, Axis, Russians or Solitaire. I chose the Axis side.
6 German cards drawn, discarded 2 cards. Played some moves. Saved this file.

When I loaded this file on my notebook I could not choose any side.
Starting to play with the Russian I can move units normally but I can not draw any Russian cards! :frowning:

I can send my saved file if needed. Would like to meet online using Vassal/Skype, too.
Hope NR-The Russian Front will run normally on my pc/notebook soon again…


But that is not how you start an online game. One player start the game, the other player does NOT start a game, but connects to the room and, right-clicks on an existing player and selects ‘Synchronize’.

In Vassal version 3.2, this becomes a lot simpler because you auto-synchronize with the first player in a room when you join it.

I followed your procedure and this worked perfectly for me, I could draw Russian cards no problem. Here is exactly what I did, please compare with what you are doing:

  1. Loaded up the 1.4.1 NR module.
  2. Started a new game using Scenarios → Barbarossa/Campaign option
  3. From Observer/Axis/Russian/Solitaire options, selected Axis
  4. Opened the two hand windows, I can draw Axis cards but not soviet cards.
  5. Saved the game as NR-test.vlog using Save Game… menu option and closed the game
  6. Not having another PC handy, I now change my Vassal user name and password to something different
  7. Load up NR-test.vlog using Load Game… menu option
  8. From the Observer/Russian/Solitaire options, Selected Russian.
  9. Opened the two hand windows, I can draw Russian cards but not Axis cards.

Can you try these exact steps on your PC? Then in step 6, copy NR-test.vlog over to your notebook instead for steps 7-9.

Yes, please upload the saved game.



i followed your procedure in the last note. I worked with two PCs and different Vassal-accounts and - passwords.
I have the same problem with drawings the cards from the second player in sequence as StarPit.


Hi Marco, Peter,

I have followed those instructions exactly using two different computers and the module behaves exactly as I would expect it to. On PC 1 I started a campaign game and selected the Axis side. I went to the Axis Player hand and click Draw card and a card draws. I went to the Russian Player hand and click Draw card and nothing happens. Then I saved the game and copied the saved game to the other PC. I open the saved game and Axis is no longer an option so I select Russian. I open the Axis hand and the card I drew as the Axis player is now hidden and clicking on Draw card does nothing. I open the Russian Player hand and clicking on Draw Card draws a card.

Can you please confirm that you do EXACTLY this process to the very last detail and same things do not occur? Exactly what is different to what I see?

Can you please send me the log file you create that you copy between PC’s.


Hi Brent and Marco,
have sent you both files (.log and .sav) attached at two messages.
Looking forward to your result!!


Problem solved … NOW NR RUNS FINE AGAIN! :slight_smile: :slight_smile:

Hi Brent, hi Marco,
Marco and I have tried many possibilities today to play our lovely NR again.
And finally we have found the error… better two errors.

I have always played the GERMAN version(s) of Vassal on my PC.

If you start the German version, there are three options:

  • Neues Spiel offline starten (start a new game offline)
  • Suche nach einem offline (!) Spiel (look for an offline (!) game)
  • Lade gespeichertes Spiel (load a saved game)

The 2nd point never made sense to me, because I have never searched for an OFFLINE game.
So I always started a OFFLINE game using option 01… then I activated the online function in the game.
(So it would be nice if you would translate correctly: Suche nach einem ONLINE Spiel).
This is the first error.

Well, but the MOST important point is that you cannot play NR with two GERMAN versions of VASSAL correctly.
If you start my .sav file with the GERMAN version, you cannot draw any Russian cards.
But if you start the same file with the ENGLISH version, all runs fine. WOW!

We have found this error by random when Marco started his Vassal version WITHOUT changing the language to German today.
He always has used the ENGLISH version on his notebook before but we have never talked about the language we use playing with Vassal. When the problem occured for the first time, he played on another PC with the GERMAN version installed.

I thought that the language would only change the vocabularies of the VASSAL software but the language seems to control also other functions of VASSAL.

Brent, it would be nice if you would check this.

HURRAY, NR runs again…!!!

If only ONE player runs the GERMAN version, all is fine. If BOTH players use the GERMAN version, the 2nd player cannot draw any cards.


Sounds like a bug in the German version of the module to me. I don’t see a German version on the vassal website.

There is no german version of the module, he has his VASSAL set to german.

Well, I can only say that there is a translation bug and that the the German settings of VASSAL produce a mistake playing NR. Marco has found the same error in Twilight Struggle using the German settings of Vassal. Maybe also a prblem when playing A Victory Denied and trying to flip the Victory Chits. I will check today if The German version, if BOTH players use them, produces a mistake at A Victory Denied, too.

Ok, I have reproduced the problem. It looks like if your language is set differently to the person who saved the game, then you load the module automatically as a side that is neither Observer, nor either of the defined sides. Notice how when you load the game, it does not ask you for which side you want to take like it should, it just loads straight up. Also, you will notice that there is no Retire option, the Player Sides have been completely lost.

It does not seem to happen with all modules. I confirmed the bug occurs with NR-Russian Front and A Victory Denied, but could not reproduces it with Panzerblitz.

I have opened

Bug 4764 - Losing Player Sides when opening module with different language set.

and will look into it. Your workaround is to ensure both players use the same language setting.


I’am so happy, that Peter and I have found the error. It was random that we are founded.
Thanks to Brent for his help and use!
Sorry my english is not so good, but I hope you understand me anyway ;-)

gr, Marco