No seeing all the changes after editing module

Java 1.6.0_29
Vassal 3.1.17
Editing the “A Few Acres of Snow” module 2.0

Applying some changes/corrections to A Few Acres of Snow from 2.0 to 2.1 with some minor improvements/corrections, so that change the game state, namely changing the shortcut to send a the discard decks to the draw decks.
but when I run the module the menu deck menu items are unchanged, both in title and shortcut key.

Added zoom functionality to the player card hand windows, that change has stuck and works fine.

It is as if I am looking at the wrong module, so I remove it from the vassal list and add it again, checking the path. If I edit the module and change the version it shows the altered version number, so I am editing the correct module, but why do the discard deck changes not show ?

what am I missing ?

You’re probably seeing a saved game that loads at game start. Check in the editor under Pre-Defined Setups…there’s likely a scenario file defined there (a .vsav file).

A saved game is a snapshot of the piece traits at the time it was created. Changes to the pieces in a module (like cards) don’t affect saved games (but usually toolbar buttons can be added ok, which is why you could add Zoom to the player windows).

You need to run the Saved Game Updater on the original .vsav file, (or set up the scenario again from scratch), then re-add it to the module.

Also keep in mind that changes made and saved to a mod will not necessarily appear if you play test it without actually closing the mod and re-opening it. I’ve made the mistake in the past of thinking my mod was really whacked out when all I really needed to do was close it and re-open it.

I’ve never once gotten the Saved Game Updater to work, so I always rebuild my scenarios from scratch. It is an annoyance, but I can be sure all the changes will be incorporated.

Thanks for the prompt replies, I will try updating the saved game as it does use one. I have tried reopening the module, this is the first time any changes I have made had not shown… so it’s the first time I have encountered this particular type of problem.

No luck with the save game updater…but the save game is the definitely the cause of the problem, as you lads suggested. After removing the saved game the changes worked as expected !, now I have to recreate the standard game setup.

thanks for all your help