Not recognizing vmod files as a vassal module

Windows 10 Pro
Memory: 16 GB
Vassal 3.6.8??? - 3.6.19
Module: A_Time_for_Trumpets_v2.9.vmod

I recently purchased the game A Time for Trumpets and downloaded its Vassal module. When I tried to open the module in VASSAL, it said I needed to update to a later version. I downloaded 3.6.19, re-installed, restarted the game and when I tried to open the module, it said "A_Time_for_Trumpets_v2.9,vmod failed: Not a Vassal module.

I reinstalled a order version of VASSAL and got the same error. I tried to open another vmod file and also got the same error.

This error log is from the older version of VASSAl as it was the last attempt I made. If you want to see an error log from the 3.6.19 version let me know

What is your system reporting as the file size of:


On my system it is 105,850 KB, or approximately 103 MB. I’m curious if your download got truncated.

EDIT: For posterity’s sake, it’s worth reminding readers that reinstalling VASSAL is almost never a solution to a problem you’re having.

105,850 kb , the same as yours.

As Paul Harvey use to say, “not why, just what”. For t he third time, I went through all the steps of updating to 3.6.19. This time, it loaded the module with no error. I can only assume that I made a mistake in updating the first two times I did it. I would like to thank JoelCFC25 and anyone else who took time to check on this program. As of right now, the problem seems to be solve and no further assistance is required.