painfully slow map load in 3.1.x

Using 3.1.13 (and previous 3.1.x versions), maps in some modules (World in Flames 6.21 and a playtest module for 1866 with a much smaller map than WIF) are loading painfully slowly. 15 minutes slow. And once loaded, if I go to another part of the map and stay there long enough, other parts that had been displayed disappear again.

The maps for these modules work fine with vassal 3.0.7. Other modules’ maps seem to load OK. But WIF and 1866 are the two I play the most!

Joel has answered some of my questions on boardgamegeek (and I tried some of his suggestions, none of which have worked so far), but I wanted to post here in case others have the problem or ideas.

Model: Cyberpower
OS: Vista (64 bit)
CPU: Intel Core 2 Duo CUP E8400 @3.00 GHz
Memory: 4 gig
Video card: NVIDIA GeForce 9600 (512 meg dedicated video memory)
Java: 1.6.0_15
Vassal 3.1.13

I don’t know how to reproduce it - I can’t stop it from reproducing itself!

No thoughts, suggestions, simlar experiences? :frowning:

Well, a quick test on my 4Gb machine with 32 bit Vista and 1024Mb Heap size as per instructions and the maps load instantly. Even using default heap sizes was usable.

My guess would be some issue with 64Bit Vista. Anyone else with 64Bit Vista able to test this for us?