Possible VASSAL Key Command Issue


I created version 5 of the Wing Leader VASSAL module in June 2021. It’s available on the VASSAL modules page. Everything worked normally when posted.

I’ve recently discovered that the aircraft counter CTRL+R key command is causing the aircraft counter ID and Label text fields to be overwritten with the aircraft counter “tallied by red” text label which is set by CTRL+ALT+R. If the “tallied by red” text label field is blank, then the ID and Label text fields are blanked as well. CTRL+R is a trigger that invokes a CTRL+ALT+SHIFT+R command. It doesn’t tie to CTRL+ALT+R as far as I can tell.

The same is true for the aircraft counter CTRL+ALT+F key command. This splits a squadron counter into two flight counters. The ID and Label fields should be retained but are overwritten by the “tallied by red” text label. CTRL+ALT+F is a trigger that invokes a CTRL+ALT+SHIFT+F command and is not tied to CTRL+ALT+R as far as I can tell.

I haven’t found any other issues with any other key command combos.

I can’t figure out why this is happening. Everything worked in June 2021 and at some point, has stopped working. I’ve made no changes to the module.

I’m wondering if a VASSAL update since June 2021 may have introduced a code change that somehow invalidates some VASSAL key command combos. If so, I’ll have to change those. If not, I’ll post more information on this issue.

Thanks very much for your help.


What is the last version of Vassal where you don’t see the problem? At the start of June 2021, the current version of Vassal would have been 3.5.6.

This is most likely due to fixing the bugs in Replace With Other over how it copies state to new pieces. It was totally broken before, now it is copying state that wasn’t before.

The specific Control keys are not significant, it’s the setup of the Text Labels in the original and Replace piece.

I think I have spotted a bug, I will investigate deeper tomorrow. Looks like multiple labels in the same piece will interfere with each other.

I have a new build 12841-replace-labels that will appear in Builds of vassalengine/vassal soon, can you give that a try and see if it resolves the problem?

There is an issue reported in VASL that may be related.

1 Like

I’ll figure this out if Brent’s snapshot version doesn’t fix it. Thanks Joel.

Build 12841 fixed the problem Brent. Thank you!

1 Like

I used the Windows 64 bit version of build 12841.

Thanks Al,

The fix will go into 3.7.5.



It’s merged. The fix will be in all 3.7.5 development builds from here on.


Awesome! You guys are much appreciated. Thanks Brent and Joel.