Problems getting Vassal started on mac

Hi there. I am having some problems getting any version of vassal to run on my iMac. I am sure I am doing something wrong that is very simple but nonetheless I am stuck.

No matter which file I download (3.1.13 and 3.1.14) vassal does not work. I drag the vassal file to either my desktop or my applications folder. When I click on the icon to run the program, it quickly shows up in the doc for a split second and then goes away and nothing happens. If I try a quick launch to have it launch in safari or firefox, the program hangs. A dialog box pops up which says readme.html and nothing happens. I clicked on the java test link and I have the latest version of Apple java (1.6.0_17 from Apple Inc) and according to that site, everything is ok on the java end.

Here are my specs:

Model Name: iMac
Model Identifier: iMac11,1
Processor Name: Intel Core i5
Processor Speed: 2.66 GHz
Number Of Processors: 1
Total Number Of Cores: 4
L2 Cache (per core): 256 KB
L3 Cache: 8 MB
Memory: 4 GB

ATI Radeon HD 4850:

Chipset Model: ATI Radeon HD 4850
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: ATI (0x1002)
Device ID: 0x944a
Revision ID: 0x0000
ROM Revision: 113-B9110C-425
EFI Driver Version: 01.00.383
Resolution: 2560 x 1440
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort

Any help would be appreciated. Thanks.

On Feb 4, 2010, at 10:22 PM, mikeg99 wrote:

OK. From the specs it looks like this is one of the new 27" iMac quad
core machines. So I presume that you are running the Snow Leopard
operating system (10.6.x). I checked the JavaApplicationStub that’s
in 3.1.13 and it has a 64bit architecture version, so it should run on
a Snow Leopard system that only has a 64-bit Java implementation. I
looked at the other files in the application and there doesn’t appear
to be anything in the way of native libraries anywhere that could lead
to issues with 32 versus 64 bit operation. So I’m at a bit of a loss
to explain this. And I can’t test it under Snow Leopard.

Is there any information on the system or console logs? You can view
those by launching the Applications > Utilities > Console application
and looking at what is there. Also, you should look in your home
directory for a file called errorLog in the VASSAL directory.

I tried running this under Leopard (10.5.8) using 32-bit Java 1.5, 64-
bit Java 1.5 and 64-bit Java 1.6 and it launched correctly under all
of them, but there was an odd “Error 14: Bad address” message in the
log. The logs all looked the same except for the Java version. I
don’t know if that would be a problem? Here is my log for that, but I
don’t know if it is related.

05 Feb 2010 16:44:51.195 0 – Starting
05 Feb 2010 16:44:51.197 0 – OS Mac OS X
05 Feb 2010 16:44:51.197 0 – Java version 1.6.0_17
05 Feb 2010 16:44:51.197 0 – VASSAL version 3.1.13
05 Feb 2010 16:44:51.646 0 – Manager
05 Feb 2010 16:44:52.492 0 Error 14: Bad address
05 Feb 2010 16:44:52.492 0

Messages mailing list …

Post generated using Mail2Forum (

It is a new 27" quad core i5.

I’ll check the console stuff tonight when I get home.

Thanks for trying to help. I need my vassal fix!

Here is what the Console Log says:

2/5/10 10:47:12 PM [0x0-0x16016].org.vassalengine.VASSAL[272] VASSAL: IO error
2/5/10 10:47:12 PM [0x0-0x16016].org.vassalengine.VASSAL[272] /Users/Mike/VASSAL/key (No such file or directory)
2/5/10 10:47:12 PM [0x0-0x16016].org.vassalengine.VASSAL[272] at Method)
2/5/10 10:47:12 PM [0x0-0x16016].org.vassalengine.VASSAL[272] at
2/5/10 10:47:12 PM [0x0-0x16016].org.vassalengine.VASSAL[272] at VASSAL.launch.ModuleManager.main(
2/5/10 10:47:12 PM [0x0-0x16016].org.vassalengine.VASSAL[272] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2/5/10 10:47:12 PM [0x0-0x16016].org.vassalengine.VASSAL[272] at sun.reflect.NativeMethodAccessorImpl.invoke(
2/5/10 10:47:12 PM [0x0-0x16016].org.vassalengine.VASSAL[272] at sun.reflect.DelegatingMethodAccessorImpl.invoke(
2/5/10 10:47:12 PM [0x0-0x16016].org.vassalengine.VASSAL[272] at java.lang.reflect.Method.invoke(
2/5/10 10:47:12 PM [0x0-0x16016].org.vassalengine.VASSAL[272] at
2/5/10 10:47:12 PM [0x0-0x16016].org.vassalengine.VASSAL[272] at apple.launcher.LaunchRunner.callMain(
2/5/10 10:47:12 PM [0x0-0x16016].org.vassalengine.VASSAL[272] at apple.launcher.JavaApplicationLauncher.launch(
2/5/10 10:47:12 PM[192] ([0x0-0x16016].org.vassalengine.VASSAL[272]) Exited with exit code: 1

Hmmm. I had a problem recently launching a newly installed Vassal
application on my Mac after it had an OS re-install. It was not able
to open the older Preferences file. I was able to clear up that
problem by making sure I had a VASSAL directory created in my home
directory. For some reason the program was not able to otherwise work.

So, I would first try creating a VASSAL folder in your home directory
and see if it solves the problem.
If there already is one, try renaming the existing one, starting
Vassal, deleting the new folder and naming the other one back.

[Note to developers: I wasn’t able to figure out how to get this to
fail again. If there is no such directory, it creates a new one.]

On Feb 5, 2010, at 9:49 PM, mikeg99 wrote:

Messages mailing list …

Post generated using Mail2Forum (

Creating a folder for vassal in the home directory worked!!!

Thanks a bunch.