Repeated Graphics Tiling - New Java Update?

I’m running Win 7 64-bit on a laptop. Vassal v3.2.15

I installed the latest Java version 8 Update 60 (build 1.8.0_60-b27) and now my module tiles the graphics every time I Open or Edit it.

Thinking it might be some sort of glitch, I “removed” the module from the library. I then went into the “tiles” folder and deleted all graphics. I reloaded the module and it tiled the graphics as I expected. Once it was loaded, I saved the module (without making any changes to it), closed it and re-opened it. It immediately began re-tiling all the graphics again.

However, when it’s tiling the graphics a second time around, it does not create a new folder in the “tiles” directory. So, it’s basically just overwriting the current graphic tiles.

I’ve been working on the module all day and only started having this problem when I decided to update my Java.

I also rebooted my system, figuring that maybe there’s some java settings that aren’t fully in place unless I reboot but that hasn’t solved the problem.

Also, when it begins tiling graphics, the “Cancel” button doesn’t do any good …it just keeps going. But, when it’s done, the module doesn’t load.

Next, I unistalled Vassal 3.2.15 and re-installed it and ran the module. That didn’t solve the problem either.

I went to my XP 32-bit system (that I have NOT updated Java on) and the module loads up just fine without tiling the graphics.

So, at this point, I can only assume that the latest Java version is the problem.

Since my module is extremely graphics intensive (80 megs), the module takes about 5 minutes to cache the graphics every time I start it. This is not good.

If I have to revert back to an older version of Java, what is the last known stable release?



I also have a Vista 64-bit system and I installed the latest Java on that computer, as well. Strangely enough, I don’t have a tiling issue. So, I have no idea what’s going on with the Win 7 computer.

Any ideas?


The mod is in a dropbox so it syncs across all the computers. I did some minor editing on the mod on my XP system and when I went back to the Win 7 computer, it stopped tiling graphics every time I started it. Go figure.

I guess it’s no longer a problem …at least for now.

I am having the same problem with the Robinson Crusoe module on Win 10. It does it every single time just as he described. Cancel just cancels the current image that it is tiling but does not stop the tiling process.

This is wasting so much time! There are not a lot of big files in RC but lots of little ones and it takes forever.

I don’t know how to tell what version of Java I am using but the last time it updated was fairly recently I think.

Has anybody found a solution?

In the VASSAL ‘Tools’ menu, there’s a ‘Clear Tile Cache’ item - I have no idea if that would help, but it’s probably worth a try.

Incidentally, you can find out your java version by entering this on the command line:

java -version

Thanks for the reply! I tried the ‘Clear Cache’ item and it is still doing it.

My Java version is 1.8.0_60-b27

Any other ideas?

It looks like the VASSAL module editor isn’t setting the timestamps of files within the module when it saves it. The images are being re-tiled because without that timestamp, VASSAL can’t tell whether the cached tile is up to date.

The only workaround I can think of is to manually unzip the module, set the modification timestamp on all the unzipped files, then zip the module back up again. I’m using Linux so I used the ‘touch’ command to set the timestamps. I’m not sure about Windows -
it might actually be easier; Windows might do it automatically when they’re unzipped.

Ok. I will try editing the module info file in the archive. That might do it.

I don’t know how to timestamp a file but hopefully this will work.


I’m having the same issue with a module that I updated recently. It will tile the images upon every launch. I’ll keep watching to see if the timestamp workaround works or if there’s another answer.

So this only appears to be happening on my computer (the one that I built the module on). It doesn’t happen on my laptop nor my brother’s computer. I’ve tried clearing the tile cache and even manually removed the folders within “e” and then restarted, let it tile, closed and tried again but it tiles every time.

I next cleared the tile cache, removed the module from the library, moved the module to a different location on my HDD and tried again but it still tiles every time.

There’s got to be a simple answer here since it’s not happening on other computers I would think.

That is strange.

Nothing I have tried so far has made it stop. It is only that one module too.

FWIW, I also have java version 1.8.0_60-b27.

Java just updated today again and it is still doing it.

Same problem here.

Java version 8.65, Java Heap set to 2048 MB and less than 400 MB Physical memory used (Resource Monitor).
Test done on both Win 7 and Win 10 (64bit) with at least 6GB RAM.

Processing images tiles seems unavoidable, every time I load a Module.


I downgraded Java version from 8 to 7 and the problem disappeared…

Where do you download the older version of java from? The tiling is driving me crazy…

I’m going to try something - if you look at the OP’s first messages, he “solved” the issue by editing the module on another computer and saving it. The one module that is doing the repeated tiling is one that I had just finished editing on my Win7 desktop. I was testing out some changes so would edit, exit, open (re-tile), edit, exit, (re-tile) dozens of times on that computer so I’m thinking that has something to do with it looping the tiling. I’m going to edit the module however slight on another PC, save and then copy it to my desktop to see if the issue goes away. I’ll let you all know.

Yes, I did originally post that after editing the module on my XP system, it stopped tiling on my Win 7 system. However, the module is now tiling every time I start it on my Win 7 system regardless of what machine I edit it on. Haven’t had any problem with repeated tiling on my XP system.

I don’t particularly want to downgrade Java to fix this.

I figured out something that worked. I don’t know why it worked, it just did.

First, I messed with the mod in several different ways on the Win 7 system to no avail …it would still tile graphics whenever I started it. So, I tried the following:

All my computers have a common DropBox folder so any changes made to the mod is transferred over to the other systems.

I opened the module on the Win 7 system, let it tile its graphics, and then closed it.

I went to my Win XP system and opened the module in the editor. I went to the main game properties, deleted the version number, and then re-typed it. Basically, I’m not making any change at all, really. Then I saved it.

I let the module finish it’s transfer through DropBox and tried to open it on the Win 7 system. It opened right up without tiling. Weird, huh?

I have the same problem with 2 mods I created and use frequently, so I explored.

WHAT I DISCOVERED. I opened both mods with 7-zip. I noticed that all the images had a modification date of dec 31, 1969, which is probably a zero. The creation dates were rational.

So I extracted all the images. I then forced them to have valid modification dates. I have Windows 10, so to do this, I selected all image files, and then rotated all of them left then right, which caused them to be modification-stamped with the current time. (After selecting images, choose “Manage” on the toolbar, and the rotate option buttons appear.)

This works for pngs and jpegs but not gifs. (I still use gifs for images with partial transparency because I’ve had problems with pngs and some users.) For gifs, I had to recreate them as new. I then put everything back into the mods. Result? It worked. No more incessant tiling after the first time.

WHAT CAUSE THIS. I have no fricking idea. It was in 2 mods I’m currently using, and the 2 I most currently edited. I randomly checked some old modules (including the newish Victory in Europe) and saw no problems. If it were me, I’d look at the vassal editor first because I think it should be the only app that does not open files readonly.

I can confirm that new Java + old timestamps do indeed cause repeated tiling upon startup.

By changing the timestamp on all images I was able to circumvent the problem.