RGhost issue

I am trying to build the latest code (3.5.2) using “mvnw install”. When it gets to the documentation phase, asciidoctorj produces the following error:

Ghostscript not found in your system environment (mswin32). Install it and set the variable RGhost::Config::GS[:path] with the executable. Example: RGhost::Config::GS[:path]='/path/to/my/gs' #unix-style RGhost::Config::GS[:path]="C:\\gs\\bin\\gswin32c.exe" #windows-style

I have GhostScript 9.53.3 installed. I also have Ruby 27 installed, with the RGhost in its gems. In the rghost.rb file, I set RGhost::Config::GS[:path] to point to gswin64c.exe, and I have successfully run a ‘hello rghost’ Ruby program to verify it works. I have set both GEM_HOME and GEM_PATH to the parent directory of all the gems.

I am running mvnw out of a Git Bash (WINGW64) shell. I am using Java v11.0.5 to compile.

What else do I need to do to convince asciidoctorj that I have Ghostscript installed?

No idea if this will help your problem, but the latest stable release of Java 11 is 11.0.10 (at least, that what my Kubuntu system has auto-updated to). Updating might help (although it’s doubtful).

It’s nothing to do with Java.

This is happening on our build system on Travis, which is also Ubuntu, but doesn’t happen for me locally on Fedora. If you figure out what’s wrong, I’d appreciate knowing.

Are any of the VASSAL developers using Windows? I should have mentioned that I’m on a Windows 10 machine.

When I get a free moment, I’ll try compiling the asciidoctorj code and run a test program, to see if I can convince it where to find Ghostscript.

I switched our CI setup from Travis—where this wasn’t working—to GitHub Actions just now. What we’re using on GitHub Actions for builds looks like Ubuntu 18.04.5 right now. Initially I was getting the same error as above, but after installing ghostscript (‘sudo apt-get install ghostscript’), the asciidoc plugin was satisfied and I no longer have a problem.

You can see build logs here: github.com/vassalengine/vassal/actions

OK - it builds on Ubuntu. Has anyone been successful in building VASSAL on Windows?

I attempted to build the latest code base (3.5.5) on Windows, and I still get the same RGhost error as in the top post. Any suggestions on how to convince asciidoctorj that I do have ghostscript installed?

Brent and I were wrestling with this earlier today, without any success.

What’s the path to your Ghostscript executable?

I run Windows and I’m able to build/use/develop with the latest code base (I use the IntelliJ IDE).

HOWEVER, the project does NOT build in maven for me – I get the same ghostscript error as you.

On the other hand, I never actually noticed that in all these months, since I don’t really need to build the full maven-whatever in order to develop on the codebase. I only end up running mvn commands “when something goes wrong” and I need to force some kind of project cleanup.


We wrestled around some more and then discovered this:

github.com/asciidoctor/asciidoc … ssues/1790

Which makes it look like asciidoctor fixed this issue in October, but the latest release of the maven-plugin version was in September (dun dun DUNH).

Confirmed asciidoctor “is just broken on Windows right now”.

Here you can follow our tale of woe, despair, and possible-eventual-redemption:
github.com/asciidoctor/asciidoc … issues/527

Thanks for tracking this down with the asciidoctor-maven-plugin developer! In the meantime, I’ll just skip the asciidoctor step of the build.

Try setting “-Dasciidoctor.attributes=!optimize” as an argument when you run maven. (This was suggested by one of the asciidoctor devs.)

Hey @uckelman - I can confirm that it is also broken under VS Code on M1 macs. But if I run ‘make jar’ everything runs fine. Thanks to these bits you added: jar: SKIPS:=-Dasciidoctor.skip=true -Dspotbugs.skip=true -Dlicense.skipDownloadLicenses