Running Vassal Under Ubuntu

I have unpacked and command line installed vassal: home/james/vassal/VASSAL.sh
I have unpacked and command line installed Java: /home/james/java/jre1.6.0_25

This took me a day and a half to figure out

  1. can someone please tell me the command to run the program?

  2. can someone please consider a ubuntu specific installer that doesn’t use the command prompt?

  3. is there a shortcut I can create that will do the command prompt for me so I can just click a button in the future?

Us Linux neophites are very confused, lost, and alone.

Thank you in advance!!!

Thus spake Shalbatana:

[This message has been edited.]

I have unpacked and command line installed vassal:
home/james/vassal/VASSAL.sh
I have unpacked and command line installed Java:
/home/james/java/jre1.6.0_25

This took me a day and a half to figure out

  1. can someone please tell me the command to run the program?

VASSAL.sh

This is a shell script, which you can recognize by the “.sh”. This is
a common way to run things in Linux.

  1. can someone please consider a ubuntu specific installer that doesn’t
    use the command prompt?

To the best of my knowledge, none of the developers use Ubuntu, so we
have no experience with building Ubuntu packages. If someone wanted to
contribute one, we wouldn’t be opposed.

  1. is there a shortcut I can create that will do the command prompt for
    me so I can just click a button in the future?

That depends on whether your desktop envrionment supports shortcuts.
The command you want the shortcut to run is VASSAL.sh.


J.

hmmm. If I click on that. I get a prompt to run in terminal, display, cancel, or run

If I run… nothing happens
If I display… it comes up as a text file
If I run in terminal, I get some flashes of windows, then nothing.

I think it’s not seeing my java install. I installed Java after vassal, could that be it?

Installing Java by hand is much harder than installing it directly from the
Ubuntu repositories.

I suspect your Java installation is not on any recognized path.

Where did you install Java?

  • M.

On 1 June 2011 16:52, Shalbatana proximapz@yahoo.com wrote:

hmmm. If I click on that. I get a prompt to run in terminal, display,
cancel, or run

If I run… nothing happens
If I display… it comes up as a text file
If I run in terminal, I get some flashes of windows, then nothing.

I think it’s not seeing my java install. I installed Java after vassal,
could that be it?

see first post

If I were you, I’d uninstall that and install from the repositories. There
are some switches in the /etc directory that determine the Java run-time
environment preference.

  • M.

On 1 June 2011 17:05, Shalbatana proximapz@yahoo.com wrote:

see first post

Thus spake Shalbatana:

hmmm. If I click on that. I get a prompt to run in terminal, display,
cancel, or run

You don’t click on it. You run it in a terminal.

If I run… nothing happens
If I display… it comes up as a text file
If I run in terminal, I get some flashes of windows, then nothing.

I think it’s not seeing my java install. I installed Java after vassal,
could that be it?

What’s the output of ‘which java’?


J.

I’ll downlad from the package installer. I thought I had done that a while back (I believe java is working fine in firefox) but maybe not.

“which java”… is that something I enter at the terminal prompt? If so… nothing

Thus spake Shalbatana:

I’ll downlad from the package installer. I thought I had done that a
while back (I believe java is working fine in firefox) but maybe not.

“which java”… is that something I enter at the terminal prompt? If
so… nothing

Yes. That means that java is not on your path. This is why you’re not
able to run VASSAL.


J.

“which java”… is that something I enter at the terminal prompt? If
so… nothing

This is what we would call a “bad sign”.

The Java in firefox is actually a slightly different package.

  • M.

Just a followup report for anyone else needing help.

(with some [hopefully] amusing backgound)
I’m trying to do this on a netbook (eeepc900), with only 4gb SSD. It’s my son’s but it’s great for writing on my long commute. I wanted to use it to work on a module I’m building.

…so I installed java from an ubuntu package, but the comp ran out of room and locked up. Then I couldn’t get it to restart due to a “power preferences not set [corrupted]” error or something.

I had to reinstall the OS, fine since I wanted to do that anyway, but I think I lost a bit of work on two documents I wasn’t able to recover because the permissions were locked.)

Anyway, long story longer… I got the OS back up, installed Java package (used Ubuntu coffee, or something - I forget the exact name, but it was one of the general JRE kits. Didn’t need any of the extended instruction packages). I installed vassal and it all worked as it’s supposed to.

unfortunately the computer only has 512mb memory and the vassal editor crashes with some overflow error or something. I’m sure it’s not made for running on such a simple machine, but I thought I’d give it a try anyway. Guess I’ll stick to working on it at home.

thanks for your help guys!

The default maximum heap is, in fact, your entire memory.

Open up a terminal and type:

java -Xmx300m -cp ./VASSAL-3.1.15/lib/Vengine.jar VASSAL.launch.Editor -e
“./Downloads/Twilight-Struggle-Deluxe-3.0.9a.vmod”

except change the VASSAL-3.1.15 part to where VASSAL is installed and change
the ./Downloads/Twilight-Struggle-Deluxe-3.0.9a.vmod to any module you have.

then in the module, click on File->Preferences and in the General tab set
the “JVM maximum heap (in MB)” to 300

If that doesn’t work, you should just give up. In any case, there might be
a couple of modules that simply won’t work well.

  • M.

On 3 June 2011 14:31, Shalbatana proximapz@yahoo.com wrote:

[This message has been edited.]

Just a followup report for anyone else needing help.

(with some [hopefully] amusing backgound)
I’m trying to do this on a netbook (eeepc900), with only 4gb SSD. It’s
my son’s but it’s great for writing on my long commute. I wanted to use
it to work on a module I’m building.

…so I installed java from an ubuntu package, but the comp ran out of
room and locked up. Then I couldn’t get it to restart due to a “power
preferences not set [corrupted]” error or something.

I had to reinstall the OS, fine since I wanted to do that anyway, but I
think I lost a bit of work on two documents I wasn’t able to recover
because the permissions were locked.)

Anyway, long story longer… I got the OS back up, installed Java
package (used Ubuntu coffee, or something - I forget the exact name, but
it was one of the general JRE kits. Didn’t need any of the extended
instruction packages). I installed vassal and it all worked as it’s
supposed to.

unfortunately the computer only has 512mb memory and the vassal editor
crashes with some overflow error or something. I’m sure it’s not made
for running on such a simple machine, but I thought I’d give it a try
anyway. Guess I’ll stick to working on it at home.

thanks for your help guys!

I had the same problem but now solved.