Set Global Property


I have a global property"Compteur_Clones" which is numeric

When I try to set its value via “set global property”, I check the is numeric field and goes on by adding a new command like this: “set value directly” at $Valeur$.

Then the value that is set just the string “Valeur” instead of the value of $Valeur$

I thought I had done something wrong again (I must say that Vassal is a very hard tool to use and will probably complain ie suggest improvements in another therad later, there are so many things to say…), but I found out that if I unchecked the isnumeric box in the “set global property” dialog box then it worked fine…

A bug then I suppose.

Nowhere did you describe what the property Valeur was, where it is, or what it could contain and evaluate out to.

Without that information or a link to a module demonstrating the problem - how are we supposed to help and tell you if you are doing something wrong or if you have indeed found a bug?

$Valeur$ is a dynamic property that is defined as numeric in the same prototype as where I use it.

Sorry for forgetting that, but I probably missed it because subconsciously I did not find it relevant.

I hope you have enough information now.

Kind regards.



Do you have first declared the named “Global property” at the right place ?

By right place i would say : inside the Main Map or outside ?



I ran a test and there is no bug. It is something you are doing that is not right but without seeing the module I can not say what
Attached is a simple demo inside the zip showing how to set a DP value and then pass the DP value to the GP value. It reports the GP value before and after it has changed for you to see.

Well, I won’t be able to send you a version with the bug. I have just tried with my latest version and checking the is numeric field does not change anything.

So, there was indeed something that made the module sensitive to the “is numeric” checkbox, but I don’t know what that was.

Thx for your time anyway.