Skype and VASSAL compatibiliy

Hi there!
I have a remanent bug using Skype and vassal at the same time.
Opening skype first, I have all sounds OK.
Running then VASSAL, no more sounds on SKYPE, and EVEN in the whole computer.
I suspect that skype is using ALSA and VASSAL too, so …
Can anyone try to solve this bug?
Many thanks!!!

If VASSAL is really at fault here, it would actually be a bug in the underlying Java library–I suggest you try updating your Java JRE, and see if that makes a difference. VASSAL just uses standard library calls for playing sounds.

Edit: VASSAL should work fine with any Java JDK from version 11 onwards; I’m using version 17 on my Linux system.

Hi jrwatts,

I use the latest openjdk version (18 or 19). VASSAL runs fine alone.
My problem is when I run SIMULTANEOUSLY VASSAL and SKYPE, I can’t speak with my partners on skype, and play on vassal.
Even if I cut the sounds in the “preferences” menu in vassal, the problem persists.

Both are using the system sounds and hardware, through ALSA I think.
So this could be a problem of resource sharing?
I am not an expert…

We’re only using the sound facilities Java provides. We can’t do anything about it Java doesn’t work correctly, or if something Skype is doing is causing things to fail. Sorry.

I’ve run into this problem and it’s not a Java problem.

The problem that I had is that both Skype and Vassal use the same CTRL sequence (CTRL-M).

Skype uses CTRL-M to mute the mic. Vassal uses it for other stuff (IIRC clear Mark when Moved).

Skype - Settings
General Settings
Turn off “Enable Global Hotkeys” (Skype watches for keyboard commands even when it’s not in focus).

Problem solved… (IF it’s the same issue I had…)

Note - lots of other keyboard commands used by Vassal could cause other wonky behavior with Skype.

RECOMMEND - add this to Vassal FAQ as a caution if using Skype and Vassal together.

BTW - this was something I observed in Skype in roughly the same timeframe as the OP. Had never had this issue w/ Skype before. I’m guessing that they either added a new feature to watch for commands when not in focus OR (maybe erroneously) enabled it as default in a MS update.