Stacking and Layers stop functioning/function incorrectly?

I’m not sure what has happened, as the layers and stacking were working just fine for a long time in this module I’m building, then suddenly they started to not do what they were suppose to.

What happened was, I have some pieces set with a “Does not stack” trait, and a “Place marker” trait. The placed markers were set to be placed above the piece they were being placed on. Everything was fine and worked for days, and I never touched the traits. But suddenly the placed markers started placing underneath the piece instead of on top. Both the placed marker and the piece it is placed on shared the same layer. So i tried to put the piece in a lower layer then the markers, then suddenly the markers were stacking on top of the piece. After restarting the module, the markers started placing under the piece again, despite being in a higher layer.

The layer property and the “Does not stack” trait were both shared by the two pieces originally with a single shared prototype.

I gave them both their own prototype, with the piece having a different lower layer, when they started stacking on it.

I don’t have any error message or explanation of whats causing this, except that it seems maybe I’ve overloaded too many traits/commands/ect. into the prototype/pieces/module?

I have no idea how to reproduce it. If anyone has any ideas on this id like to hear them.

  • Custom Model Computer
  • Windows XP Operating System
  • Intel Core 2 Duo CPU
  • 2 GB Memory
  • Nvidia GeFore GTS 250 Video Card
  • Vassal version 3.1.19
  • Java version 1.7.0_05

In case anyone wants to look at it:

Aditional Information on the module:
The queen piece, found in the Alien Objectives(button)/Alien Window(editor) is the problem piece, along with the pieces it “spawns” on top of it through the right click menu. If you cant spawn no more while fiddling with it, just turn the Turn Tracker forward until it hits the Aliens turn again.

Sorry for double posting, it seems I can’t edit the OP anymore.

Here’s an earlier version of the module when things still worked, for reference in case anyone might want to look at it, and possibly find any problems.

Erm… Triple posting?

Umm, well, it seems I solved the problem, and it was my fault.

If umm, anyone wants to delete this thread, they can. Sorry for the wasted space.

Thus spake reddeblu:

Erm… Triple posting?

Umm, well, it seems I solved the problem, and it was my fault.

Please tell us what the problem was—the follow-up is helpful for
anyone looking at this thread later.


Honestly I have no idea what the problem was, and still don’t. However I solved it by simply giving the queen piece a separate prototype with the exact same traits as the last prototype, and then suddenly it works. However currently when I make the queen use the old prototype, the problem returns, it beats me shrug.

I just assumed that it was something I messed up and somehow got around with the second prototype, content with it working I never really did look into the cause beyond what I already tried. But if anyone wants to explore this strange phenomenon, and maybe figure out a reason behind it, be my guest. Here’s a download again.

To restate, the problem is that, while the queen piece is using the Aliens prototype, the markers/pieces placed on the queen seem to do anything but what they were told as far as stacking and layer position. However when the queen uses a separate prototype with a copy of the same traits as the last, everything works as should be.

Note: The module has changed since the op, and the queen piece can now easily be found in the Aliens piece palette.