"Tearing" on maps and other Graphics Issues

Windows Specific Issues

If you run on Microsoft Windows and your map is not updating correctly (e.g. “tearing” or not fully updating), go to Vassal’s preferences and check the box for Disable DirectX D3D Pipeline.

Some combinations of video drivers and versions of Java don’t work well together. If you have rendering problems with Direct3D turned on and they go away when you turn it off, then you have one of those bad combinations. This preference (and potential problem) exists only on Windows machines.
Preference to fix tearing

More General Issues

If you are having tearing on maps, and are not running on Windows (or if you have already tried the Windows-specific solution above):

After the first time you run one of these builds, there will be a file called vassal.vmoptions in VASSAL’s config directory where you can add VM flags for the Player, one per line.

Linux: ~/.VASSAL/vassal.vmoptions
Mac OS X: ~/Library/Application Support/VASSAL/vassal.vmoptions
Windows: C:\Users\<username>\AppData\Roaming\VASSAL\vassal.vmoptions

Try these two lines, in order, one at a time:



The map sometime flashes onscreen & then disappears. Other times it never appears at all

This is a symptom of too little memory being allocated to the VASSAL program.

Vassal 3.1 and later allow you to set the memory for a module using the preferences for that module. Open the preferences and increase the maximum amount of memory. This value should generally be lower than the maximum amount of RAM your system has installed.

How do I make a window appear on a second display?

My computer has more than one display. How can I put a window on the second display?

  • Open the preferences panel for the module.
  • Uncheck the option “Use combined application window”.
  • Close the module.
  • Open the module again. Each panel will be in its own window, which you can place as you like.