Testing 3.5 Beta 1 - PDF Files Still Don't Work

Maybe I’m the problem, but from the description of the PDF function under Help files, all I need to do is select the PDF I want to show. For me, this has the same result as earlier versions - nothing happens. The PDFs are present in the .vmod file, but nothing shows when I run a new game from the Editor. Is it me?

The inner workings of the PDF displayer simply forwards the PDF file to your OS to use its “default method for opening a PDF”. Whatever happens when you double-click a PDF file from your desktop should in theory be what happens when you show the PDF from inside of vassal. So the first thing to do is check what your operating system’s default action for PDF is.


Well, I have Adobe Acrobat Pro that opens when I click on any PDF, so I can’t imagine that’s the issue. I even changed it to open in Chrome - again, nothing.

Check in the errorLog after you try unsuccessfully to open a PDF.

2020-11-29 15:13:45,598 [3-AWT-EventQueue-0] INFO VASSAL.build.GameModule - Exiting
2020-11-29 15:13:46,355 [0-IPC receiver for 83364104] ERROR VASSAL.tools.ipc.IPCMessageReceiver - Error while reading IPC message
java.net.SocketException: Connection reset
at java.base/sun.nio.ch.NioSocketImpl.implRead(NioSocketImpl.java:323)
at java.base/sun.nio.ch.NioSocketImpl.read(NioSocketImpl.java:350)
at java.base/sun.nio.ch.NioSocketImpl$1.read(NioSocketImpl.java:803)
at java.base/java.net.Socket$SocketInputStream.read(Socket.java:981)
at java.base/java.net.Socket$SocketInputStream.read(Socket.java:976)
at java.base/java.io.ObjectInputStream$PeekInputStream.peek(ObjectInputStream.java:2862)
at java.base/java.io.ObjectInputStream$BlockDataInputStream.peek(ObjectInputStream.java:3189)
at java.base/java.io.ObjectInputStream$BlockDataInputStream.peekByte(ObjectInputStream.java:3199)
at java.base/java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1652)
at java.base/java.io.ObjectInputStream.readObject(ObjectInputStream.java:508)
at java.base/java.io.ObjectInputStream.readObject(ObjectInputStream.java:466)
at VASSAL.tools.ipc.IPCMessageReceiver.run(IPCMessageReceiver.java:35)
at java.base/java.lang.Thread.run(Thread.java:832)
2020-11-29 15:13:49,275 [0-SwingWorker-pool-3-thread-3] INFO VASSAL.launch.AbstractLaunchAction - Loading module file C:\Users\Curt\Documents\VASSAL MODS\CGSC_Land_Power_(v1.5)Beta_1.vmod
2020-11-29 15:13:49,360 [0-SwingWorker-pool-3-thread-3] INFO VASSAL.launch.TilingHandler - No images to tile.
2020-11-29 15:13:49,362 [0-SwingWorker-pool-3-thread-3] INFO VASSAL.launch.AbstractLaunchAction - Loading module Land Power Division
2020-11-29 15:13:49,363 [0-SwingWorker-pool-3-thread-3] INFO VASSAL.tools.io.ProcessLauncher - launching C:\Program Files\VASSAL-3.5.0-beta1\jre\bin\java -Xms512M -Xmx512M -DVASSAL.id=5 -DVASSAL.port=5773 -Duser.home=C:\Users\Curt -Duser.dir=C:\Program Files\VASSAL-3.5.0-beta1 -cp lib\Vengine.jar VASSAL.launch.Editor --edit – C:\Users\Curt\Documents\VASSAL MODS\CGSC_Land_Power
2020-11-29 15:13:50,169 [5-main] INFO VASSAL.launch.StartUp - Starting
2020-11-29 15:13:50,178 [5-main] INFO VASSAL.launch.StartUp - OS Windows 10 10.0
2020-11-29 15:13:50,178 [5-main] INFO VASSAL.launch.StartUp - Java version 15
2020-11-29 15:13:50,178 [5-main] INFO VASSAL.launch.StartUp - VASSAL version 3.5.0-beta1
2020-11-29 15:13:50,178 [5-main] INFO VASSAL.launch.Launcher - Editor
2020-11-29 15:13:54,404 [5-AWT-EventQueue-0] INFO VASSAL.build.GameModule - Land Power Division version CGSC 1.5 (3.5 Beta 1)
2020-11-29 15:14:01,800 [5-AWT-EventQueue-0] WARN VASSAL.i18n.BundleHelper - No Translation: Wizard.Next_mnemonic
2020-11-29 15:14:01,801 [5-AWT-EventQueue-0] WARN VASSAL.i18n.BundleHelper - No Translation: Wizard.Prev_mnemonic
2020-11-29 15:14:01,801 [5-AWT-EventQueue-0] WARN VASSAL.i18n.BundleHelper - No Translation: Wizard.Finish_mnemonic
2020-11-29 15:14:01,801 [5-AWT-EventQueue-0] WARN VASSAL.i18n.BundleHelper - No Translation: Wizard.Cancel_mnemonic
2020-11-29 15:14:01,801 [5-AWT-EventQueue-0] WARN VASSAL.i18n.BundleHelper - No Translation: Wizard.Help_mnemonic

Could this be a permissions issue for the PDF viewing program set as default? I would really like to know if ANYONE else can get PDFs working in 3.5.0 by just selecting the PDF you want to display…

I’ll give it a go next week, if no-one else gets there first. I’m trying to focus on module work under v3.4 this week.

No worries.