Text Labels

Been revamping my Gettysburg 77 module and am having trouble with my text labels not maitaining their aspect to to pieces assigned to. :confused: I didn’t have any issues in my original release , though I did notice this happening sometimes while in the late development stages of my Close Assault/ Firepower module. I think a new Vassal version was released around then. Am I missing something or has anyone else experienced this?
thanks in advance

I haven’t noticed any problems myself; Have you tried changing the order of the piece traits?

Yes, It is wierd. I have several text labels on my pieces for Close Assault/Firepower, and all worked well. Then I tried to add a text label to label specific wound damge, it won’t maintain aspect. All others maintain. Then , I started reworking Gettysburg, and the first label I tried won’t maintain, deleted several times and tried through prototyes and striaght into the piece. No avail…GGRRR!. I’ll keep trying Close Assault turned out nice, I want to upgrade Gettysburg with what I learned. FRUSTRATING.

Okay, messed with it some more. Here is what I noticed. Piece has following properties: Can Rotate(R/L bracket keys w/ sub menu to turn), Move fixed distance-Line Form(NUMPAD7,9,1,3 w/ sub menu for move), Move fixed distance-column form(NUMPAD8,2 w/ submenu to move),Basic piece(no icon),Layer(6 layers, column, cav column,line,angle right,angle left, salient w/ dynamic prop to select w/ sub menu). If I put the piece on the board, enter strength value(text label bottom center), it is fine, formaion selcts fine still(layer). If I move piece , it is fine, when I turn the piece, depending on menu location of the can rotate and text label , I get one of two results…1) piece works fine, text label won’t maintain aspect…2) text maitains aspect, piece will no longer cycle through the layers. Something seems to conflict with the label and the Can Rotate. Help any?

Alright, I ran with your location advice, maybe we got it, I have dynamic property 1st, text label 2nd,Can Rotate 3rd. VASSAL maybe needs to see the label and pieces first(?) before the can rotate command to enable all these things to work right? I noticed that I can also have inaccurate move commands if I use other positions. Like VASSAL only sees the initial piece placement? HMMM. Anyway, as of now, all of these are safely tucked away in this order in a prototype for all my formation pieces and so far I think everything works. Thanks for the advice.