There's a bug in the new module 3.7.6

Hello, there’s a bug with the new Vassal version. I have a module about a TCG, after making the deck, ill save the file, open the deck box and i click “Load Deck”. When i do that, the deck is loaded in B instead of A. I tried to see if the expression is bugged or modified but there’s no problem.

How to resolve?

What is that last Vassal version where it worked OK?

It’s was working until the 3.7.3

Thanks, This was reported before (Deck is loading to a different location) but has dropped off the radar. Thanks for the new report. I have created an Issue in our bug tracker this time.


I have put up a new build that I believe solves the problem, Can you please give it a try?

VASSAL-3.7.7-SNAPSHOT-85ec1ee-13003-SavedDeckWrongMap at Builds of vassalengine/vassal

Note that the problem is in the Deck save files created with 3.7.4-3.7.6 and I can’t fix it so these will load. This fix ensures any new Deck save files will load properly.

The workaround is to load a problem Deck save file into Vassal 3.7.3, then re-save it. That will load into any version of Vassal.


1 Like

Among them all which one i need to download? The first one is good?

That build is now on page 2 … here’s a direct link if you’re quick, otherwise you’ll need to go to an even later page.

Take the build that matches your machine.

Thanks. I have another question, but this is not for a bug. I wanna know if it’s possible to add to the module a seach function for the library? having a TCG module it will be more easy for searching the cards

I replied to your thread on that question.

Tried the “VASSAL-3.7.7-SNAPSHOT-85ec1ee-13003-SavedDeckWrongMap-windows-x86_64” and it’s working :slight_smile:

Can i still wait for an “official release” before making my group download this version?

I expect we’ll release 3.7.7 sometime in January.

1 Like