Tiling Large PNG image

I am creating a new (my first) module, and it uses a large map image of 200 MB. It crashes when opening the module and tiling the map (first load, to edit). I captured the error at https://pastebin.com/tZRFQUzZ.

Socket Error
The socket over which the Module Manager communicates has had a fault. Please restart VASSAL.

Any help in resolving this issue would be much appreciated.

  • Windows
  • Vassal 3.2.17

I think the previous image was imported and causing the crash.

I added a map. A 1.6GB map. Then I realized what I had done. So I saved the module and modified the map to be 200MB. Then I opened the module to use the new smaller image. Well, the 1.6 GB file version had already been saved to the mod. So when I opened to edit, it tried to tile the 1.6GB map.

I changed the extension of the vmod to zip and replaced the image file. Then renamed it back to vmod.

Solved my issue.

That’s a massive map file still, what are the dimensions and dpi?

I don’t know off-hand. It is based on a printed map that covers two large folding tables when laid flat. So probably tens of thousands of pixels per side at 300-dpi.

The size of the image file doesn’t matter. What matters is the dimensions. Either reduce the dimensions or split the image up into several smaller ones.