Twilight Struggle Deluxe card text problem

Having a tricky problem with the Twilight Struggle 3.01a deluxe mod. I am running the latest version of Vassal (3.1.14) on my Apple PowerMac G5 which is running OS 10.5.8 (fully updated, Java included). The mod loads fine, but I am unable to see any of the card’s text. I only see the card artwork, the number and star. I loaded other mods and am able to see card text just fine. Any ideas on how to fix this?

I can not see any card text either on my iMac G5 with 10.5.8 (java update 7 not yet applied). Works fine on my Core i7 iMac with 10.6.4.

…And same problem with the java 7 update applied.

Here is a screenshot of the problem:

That is exactly the way it looks for me as well. Is this more a OS X 10.5.8 problem or a G5/Intel problem? I have tested the mod on a Intel MacBook Pro using OS 10.6.4 and have no problems.

I’ll have a look this weekend. Does anyone know if it works in Windows? Sounds like it could be a font problem.

Ken

I’m the maintainer of the module but, unfortunately, I’m in the middle of the Canadian wilderness with only an iPod and very spotty Internet access, so I can’t check this problem until I’m back in civilization. However I can tell you that the module looked fine on my MacBook Pro which I got relatively recently. I can also tell you that the cards are actually SVG files, so the problem may relate to the Batik libs or how Java 7 handles fonts. Also check if you have the Georgia font. That shouldn’t matter, however; it would just look ugly. Also check to see if the influence markers show numbers or not. If they do, then it’s likely a Batik problem. Also, try opening the individual SVG files in MacOS itself and see if you can read them.

I will check on this when I get back.

  • M.

On 2010-08-19, at 6:36 PM, Kingcake matthewguidry@gmail.com wrote:


I’m not very knowledgeable on how to edit a Vassal mod or see any of the resources. I was able to get to the properties of the card though, and still no text is visible. I followed the same path to get to the properties of the same card on my MacBook Pro and was able to see the text on the card. Hope this helps some.

Thus spake Kingcake:

That is exactly the way it looks for me as well. Is this more a OS X
10.5.8 problem or a G5/Intel problem? I have tested the mod on a Intel
MacBook Pro using OS 10.6.4 and have no problems.

My guess is that Batik isn’t able to find the required font, but
unfortunately I don’t have time to look into it right now. I’ll wait
for Michael to return from back of the beyond to sort it out.


J.

I’ve tried this on a Linux box where the font was not available and it just
did a simple substitution. It was ugly but readable.

There must be something new about the new Mac OSX releases and Batik.

I’m not in civilization yet…

  • M.

On 23 August 2010 07:57, Joel Uckelman uckelman@nomic.net wrote:

Thus spake Kingcake:

That is exactly the way it looks for me as well. Is this more a OS X
10.5.8 problem or a G5/Intel problem? I have tested the mod on a Intel
MacBook Pro using OS 10.6.4 and have no problems.

My guess is that Batik isn’t able to find the required font, but
unfortunately I don’t have time to look into it right now. I’ll wait
for Michael to return from back of the beyond to sort it out.


J.


messages mailing list
messages@vassalengine.org
vassalengine.org/mailman/listinfo/messages

I’ve tried this on a Linux box where the font was not available and it just did a simple substitution.� It was ugly but readable.

There must be something new about the new Mac OSX releases and Batik.

I’m not in civilization yet…


- M.

On 23 August 2010 07:57, Joel Uckelman <uckelman@nomic.net> wrote:

Thus spake Kingcake:

> That is exactly the way it looks for me as well. �Is this more a OS X
> 10.5.8 problem or a G5/Intel problem? � I have tested the mod on a Intel
> MacBook Pro using OS 10.6.4 and have no problems.
>

My guess is that Batik isn't able to find the required font, but
unfortunately I don't have time to look into it right now. I'll wait
for Michael to return from back of the beyond to sort it out.

--
J.

On 22 August 2010 01:00, Kingcake matthewguidry@gmail.com wrote:

I’m not very knowledgeable on how to edit a Vassal mod or see any of the
resources. I was able to get to the properties of the card though, and
still no text is visible.

What did you do exactly? I’m not a Mac person, so I’m not sure what you
did. So, you attempted to look at the card without Java and you couldn’t
see the text on your new Mac, but you could on your older Macbook Pro?

That’s kind of disturbing. Any Mac experts out there that could shed some
light on changes in font support on Macs? Unfortunately, I’m still at least
3000km from my Mac.

I also think I left it under an open window…

  • M.

I followed the same path to get to the
properties of the same card on my MacBook Pro and was able to see the
text on the card. Hope this helps some.

On 22 August 2010 01:00, Kingcake <matthewguidry@gmail.com> wrote:


I’m not very knowledgeable on how to edit a Vassal mod or see any of the

resources. �I was able to get to the properties of the card though, and

still no text is visible. �

What did you do exactly?� I’m not a Mac person, so I’m not sure what you did.� So, you attempted to look at the card without Java and you couldn’t see the text on your new Mac, but you could on your older Macbook Pro?


That’s kind of disturbing.� Any Mac experts out there that could shed some light on changes in font support on Macs?� Unfortunately, I’m still at least 3000km from my Mac.

I also think I left it under an open window…


- M.

I followed the same path to get to the

properties of the same card on my MacBook Pro and was able to see the

text on the card. Hope this helps some.

Here’s what I did. (Again, I know very little about editing a Vassal mod or programming in Java.)

I fired up the Vassal app on OS X and choose EDIT MODULE. I selected the Twilight Struggle Deluxe mod.

Via Vassal Module Editor I navigated through - Decks [Map Widow] >Draw Deck [Deck] > Asia Scoring [Card]. On this card I selected Properties by right clicking on Asia Scoring [Card].

On the PowerMac G5 with OS 10.5.8 I saw the card, background image, number of card, but no text.
On the MacBook Pro with OS 10.6.4 I saw the card, background image, number of card, with text.

I hope this helps.

The MacOS X 10.5.8 which does work has Java 1.5.0_24.
The MacOS X 10.6.4 on which it doesn’t work has Java 1.6.0_20.

Thanks for doing this and the info helps. I will be back in civilization on
Monday and will have an answer shortly afterwards hopefully.

  • M.

On 26 August 2010 04:02, bdgza bdegroot@gmail.com wrote:

“Kingcake” wrote:

On the PowerMac G5 with OS 10.5.8 I saw the card, background image,
number of card, but no text.
On the MacBook Pro with OS 10.6.4 I saw the card, background image,
number of card, with text.

The MacOS X 10.5.8 which does work has Java 1.5.0_24.
The MacOS X 10.6.4 on which it doesn’t work has Java 1.6.0_20.

Thanks for doing this and the info helps.� I will be back in civilization on Monday and will have an answer shortly afterwards hopefully.

- M.

On 26 August 2010 04:02, bdgza <bdegroot@gmail.com> wrote:


"Kingcake" wrote:
On the PowerMac G5 with OS 10.5.8 I saw the card, background image,
number of card, but no text.
On the MacBook Pro with OS 10.6.4 I saw the card, background image,
number of card, with text.


The MacOS X 10.5.8 which does work has Java 1.5.0_24.
The MacOS X 10.6.4 on which it doesn't work has Java 1.6.0_20.


Actually the other way around, at least for me.

Mac OS X 10.5.8 which doesn’t work has Java 1.5.0_24. (PPC machine)
MacOS X 10.6.4 which does work has Java 1.6.0_20. (Intel machine)

This is possibly a known problem in MacOSX. One solution that I have seen
on the Internet is to add

-Dapple.awt.graphics.UseQuartz=false

as a command-line option. I believe that Quartz is the graphics engine that
sends commands directly to the GPU? If that’s the case, then the option
seems like it would do little harm to VASSAL.

Unfortunately, I do not even experience the problem on my Macbook, so I
can’t test this. Can someone who has posted the problem give it a go?

The other problem is that I don’t know where Java options go on mac. Joel,
can you help me out here? Does mac just use the shell script that Linux
uses?

  • M.

On 26 August 2010 11:39, Kingcake matthewguidry@gmail.com wrote:

The MacOS X 10.5.8 which does work has Java 1.5.0_24.

The MacOS X 10.6.4 on which it doesn’t work has Java 1.6.0_20.

Actually the other way around, at least for me.
Mac OS X 10.5.8 which doesn’t work has Java 1.5.0_24. (PPC machine)
MacOS X 10.6.4 which does work has Java 1.6.0_20. (Intel machine)

This is possibly a known problem in MacOSX.� One solution that I have seen on the Internet is to add

-Dapple.awt.graphics.UseQuartz=false

as a command-line option.� I believe that Quartz is the graphics engine that sends commands directly to the GPU?� If that’s the case, then the option seems like it would do little harm to VASSAL.�


Unfortunately, I do not even experience the problem on my Macbook, so I can’t test this.� Can someone who has posted the problem give it a go?�

The other problem is that I don’t know where Java options go on mac.� Joel, can you help me out here?� Does mac just use the shell script that Linux uses?


- M.

On 26 August 2010 11:39, Kingcake <matthewguidry@gmail.com> wrote:


The MacOS X 10.5.8 which does work has Java 1.5.0_24.
The MacOS X 10.6.4 on which it doesn't work has Java 1.6.0_20.



Actually the other way around, at least for me. �
Mac OS X 10.5.8 which doesn't work has Java 1.5.0_24. (PPC machine)
MacOS X 10.6.4 which does work has Java 1.6.0_20. (Intel machine)

On Aug 31, 2010, at 11:39 AM, Michael Kiefte wrote:

This is possibly a known problem in MacOSX. One solution that I
have seen on the Internet is to add

-Dapple.awt.graphics.UseQuartz=false

as a command-line option. I believe that Quartz is the graphics
engine that sends commands directly to the GPU? If that’s the case,
then the option seems like it would do little harm to VASSAL.

Unfortunately, I do not even experience the problem on my Macbook,
so I can’t test this. Can someone who has posted the problem give
it a go?

The other problem is that I don’t know where Java options go on
mac. Joel, can you help me out here? Does mac just use the shell
script that Linux uses?

No.

The application bundle on the Mac has inside it an Info.plist which
allows you to set what would otherwise be command line options. It
does accept the standard flags and options, but they are stored in a
different place when you use a bundled application.

If you launch from the command line, then you can use the standard
Unix method, but the Mac Vassal package is very nicely done up as an
application.

Yes, that should obviously have been the other way around…

Okay, try this.

Go to your VASSAL folder in Finder. Right-click on the VASSAL application
and select “Show Package Contents”. Right-click on “Contents” and select
“Get Info”. Expand “Sharing and Permissions” at the bottom. Select “Read and
Write” privilege for yourself.

Download this file:
myweb.dal.ca/mkiefte/Info.plist

(right-click on the above link and select “Download Linked File” – don’t
try to open it in Safari)

Drag Info.plist from Downloads to the Contents folder mentioned above.
Close Finder and run VASSAL. Then tell me if you can see the text.

(Don’t do this if you can already see the text).

  • M.

On 1 September 2010 04:32, bdgza bdegroot@gmail.com wrote:

“Kingcake” wrote:

The MacOS X 10.5.8 which does work has Java 1.5.0_24.
The MacOS X 10.6.4 on which it doesn’t work has Java 1.6.0_20.

Actually the other way around, at least for me.
Mac OS X 10.5.8 which doesn’t work has Java 1.5.0_24. (PPC machine)
MacOS X 10.6.4 which does work has Java 1.6.0_20. (Intel machine)

Yes, that should obviously have been the other way around…

Okay, try this.


Go to your VASSAL folder in Finder. Right-click on the VASSAL application and select “Show Package Contents”. Right-click on “Contents” and select “Get Info”. Expand “Sharing and Permissions” at the bottom. Select “Read and Write” privilege for yourself.


Download this file:
[myweb.dal.ca/mkiefte/Info.plist](http://myweb.dal.ca/mkiefte/Info.plist)

(right-click on the above link and select "Download Linked File" -- don't try to open it in Safari)

Drag Info.plist from Downloads to the Contents folder mentioned above. �Close Finder and run VASSAL. �Then tell me if you can see the text.

(Don't do this if you can already see the text).

- M.

On 1 September 2010 04:32, bdgza <[bdegroot@gmail.com](mailto:bdegroot@gmail.com)> wrote:

"Kingcake" wrote:

> The MacOS X 10.5.8 which does work has Java 1.5.0_24.
> The MacOS X 10.6.4 on which it doesn't work has Java 1.6.0_20.



Actually the other way around, at least for me. �
Mac OS X 10.5.8 which doesn't work has Java 1.5.0_24. (PPC machine)
MacOS X 10.6.4 which does work has Java 1.6.0_20. (Intel machine)


Yes, that should obviously have been the other way around...

I guess the right-click menu command for the link is “Saved Linked File to
Downloads”.

  • M

On 1 September 2010 07:29, Michael Kiefte mkiefte@dal.ca wrote:

Okay, try this.

Go to your VASSAL folder in Finder. Right-click on the VASSAL application
and select “Show Package Contents”. Right-click on “Contents” and select
“Get Info”. Expand “Sharing and Permissions” at the bottom. Select “Read and
Write” privilege for yourself.

Download this file:
myweb.dal.ca/mkiefte/Info.plist

(right-click on the above link and select “Download Linked File” – don’t
try to open it in Safari)

Drag Info.plist from Downloads to the Contents folder mentioned above.
Close Finder and run VASSAL. Then tell me if you can see the text.

(Don’t do this if you can already see the text).

  • M.

On 1 September 2010 04:32, bdgza bdegroot@gmail.com wrote:

“Kingcake” wrote:

The MacOS X 10.5.8 which does work has Java 1.5.0_24.
The MacOS X 10.6.4 on which it doesn’t work has Java 1.6.0_20.

Actually the other way around, at least for me.
Mac OS X 10.5.8 which doesn’t work has Java 1.5.0_24. (PPC machine)
MacOS X 10.6.4 which does work has Java 1.6.0_20. (Intel machine)

Yes, that should obviously have been the other way around…

I guess the right-click menu command for the link is “Saved Linked File to Downloads”.


- M

On 1 September 2010 07:29, Michael Kiefte <mkiefte@dal.ca> wrote:

Okay, try this.

Go to your VASSAL folder in Finder. Right-click on the VASSAL application and select "Show Package Contents". Right-click on "Contents" and select "Get Info". Expand "Sharing and Permissions" at the bottom. Select "Read and Write" privilege for yourself.

Download this file:

(right-click on the above link and select "Download Linked File" -- don't try to open it in Safari)

Drag Info.plist from Downloads to the Contents folder mentioned above. �Close Finder and run VASSAL. �Then tell me if you can see the text.

(Don't do this if you can already see the text).

- M.


On 1 September 2010 04:32, bdgza <[bdegroot@gmail.com](mailto:bdegroot@gmail.com)> wrote:

"Kingcake" wrote:

> The MacOS X 10.5.8 which does work has Java 1.5.0_24.
> The MacOS X 10.6.4 on which it doesn't work has Java 1.6.0_20.



Actually the other way around, at least for me. �
Mac OS X 10.5.8 which doesn't work has Java 1.5.0_24. (PPC machine)
MacOS X 10.6.4 which does work has Java 1.6.0_20. (Intel machine)


Yes, that should obviously have been the other way around...