Twilight Struggle Deluxe card text problem

I agree with your calculations, except for the mid-east where I think the Soviets should get 3 VPs but I might be mis-counting. This was my second game.

I’m not sure by what you meant by scoring cards, but all the scoring cards seemed to check out fine during the game.

We did notice that the discrepancies in SA, and it looks like Brazil might be wrong too, or am I mis-reading things?

We played with v. 3.0a.

Once again - the module is quite an achievement. Thanks for your efforts!

You are correct on the MIddle East.

Your not using the most recent version (3.02a), but I have never seen this
bug before, so it probably wouldn’t make much difference.

I’m presently looking into it.

I’m amazed the Soviets won by the way. It looks like they collapsed in the
end.

  • M.

On 8 September 2010 21:34, Rooster dlpod@yahoo.com wrote:

I agree with your calculations, except for the mid-east where I think
the Soviets should get 3 VPs but I might be mis-counting. This was my
second game.

I’m not sure by what you meant by scoring cards, but all the scoring
cards seemed to check out fine during the game.

We did notice that the discrepancies in SA, and it looks like Brazil
might be wrong too, or am I mis-reading things?

We played with v. 3.0a.

Once again - the module is quite an achievement. Thanks for your
efforts!

You are correct on the MIddle East.

Your not using the most recent version (3.02a), but I have never seen this bug before, so it probably wouldn’t make much difference.

I’m presently looking into it.


I’m amazed the Soviets won by the way.� It looks like they collapsed in the end.

- M.

On 8 September 2010 21:34, Rooster <dlpod@yahoo.com> wrote:

I agree with your calculations, except for the mid-east where I think
the Soviets should get 3 VPs but I might be mis-counting. �This was my
second game.

I'm not sure by what you meant by scoring cards, but all the scoring
cards seemed to check out fine during the game.

We did notice that the discrepancies in SA, and it looks like Brazil
might be wrong too, or am I mis-reading things?

We played with v. 3.0a.

Once again - the module is quite an achievement. �Thanks for your
efforts!

Yes, I’m surprised the Soviets won, too. (I was the Soviets). The US player experience a lot of really baaaaad dice rolling, which kept me afloat much longer than I ought to have.

I am unable to replicate this problem on my end.

However, you are using the earliest version. There was a bug that I fixed
quite a while ago that might resolve this issue. Did you download this
version from the VassalEngine website, or did you get it from one of the
early playtesters?

  • M.

On 8 September 2010 22:57, Rooster dlpod@yahoo.com wrote:

Yes, I’m surprised the Soviets won, too. (I was the Soviets). The US
player experience a lot of really baaaaad dice rolling, which kept me
afloat much longer than I ought to have.

I am unable to replicate this problem on my end.

However, you are using the earliest version.� There was a bug that I fixed quite a while ago that might resolve this issue.� Did you download this version from the VassalEngine website, or did you get it from one of the early playtesters?


- M.

On 8 September 2010 22:57, Rooster <dlpod@yahoo.com> wrote:

Yes, I’m surprised the Soviets won, too. �(I was the Soviets). �The US

player experience a lot of really baaaaad dice rolling, which kept me

afloat much longer than I ought to have.

T’was downloaded from the GMT website, if I recall.

I’ll be sure to use the newest version. Thank you for checking things out! Hope it didn’t drive you too mad.

Best,

Dan

I’ll have to talk to GMT about linking directly to the VassalEngine website.

It didn’t drive me mad! But I encourage you to alert me to any problems.
Technically, it’s still an alpha module…

  • M.

On 12 September 2010 00:38, Rooster dlpod@yahoo.com wrote:

T’was downloaded from the GMT website, if I recall.
I’ll be sure to use the newest version. Thank you for checking things
out! Hope it didn’t drive you too mad.

Best,

Dan


Read this topic online here:
https://forum.vassalengine.org/t/twilight-struggle-deluxe-card-text-problem/3197/52


messages mailing list
messages@vassalengine.org
vassalengine.org/mailman/listinfo/messages


Michael Kiefte, Ph.D.
Associate Professor
School of Human Communication Disorders
Dalhousie University
Halifax, Nova Scotia, Canada
tel: +1 902 494 5150
fax: +1 902 494 5151

I’ll have to talk to GMT about linking directly to the VassalEngine website.

It didn’t drive me mad! But I encourage you to alert me to any problems.� Technically, it’s still an alpha module…

- M.


On 12 September 2010 00:38, Rooster <dlpod@yahoo.com> wrote:

T’was downloaded from the GMT website, if I recall.

I’ll be sure to use the newest version. �Thank you for checking things

out! �Hope it didn’t drive you too mad.



Best,



Dan




_______________________________________________

Read this topic online here:

https://forum.vassalengine.org/t/twilight-struggle-deluxe-card-text-problem/3197/52



--
Michael Kiefte, Ph.D.
Associate Professor
School of Human Communication Disorders
Dalhousie University
Halifax, Nova Scotia, Canada
tel: +1 902 494 5150
fax: +1 902 494 5151

Thus spake Michael Kiefte:

I’ll have to talk to GMT about linking directly to the VassalEngine website.

It would be better if they would keep up-to-date. That way, people download
the module from them, not from us.


J.

I’ll ask…

  • M.

On 12 September 2010 17:39, Joel Uckelman uckelman@nomic.net wrote:

Thus spake Michael Kiefte:

I’ll have to talk to GMT about linking directly to the VassalEngine
website.

It would be better if they would keep up-to-date. That way, people download
the module from them, not from us.


J.

I’ll ask…

- M.

On 12 September 2010 17:39, Joel Uckelman <uckelman@nomic.net> wrote:

Thus spake Michael Kiefte:

>
> I'll have to talk to GMT about linking directly to the VassalEngine website.
>

It would be better if they would keep up-to-date. That way, people download
the module from them, not from us.

--
J.

I am the original poster of this thread. I tried using the module with the build of Vassal posted here and am happy to say that the card text problem on my Power Mac G5 is fixed! Sure the text could look a bit better, but there is text on the cards, and I am very happy. Thank you for the hard work developing this mod and fixing this issue. Now, to find opponents!

Could you post a screenshot? I’m curious.

  • M.

On 13 September 2010 01:13, Kingcake matthewguidry@gmail.com wrote:

I am the original poster of this thread. I tried using the module with
the build of Vassal posted here and am happy to say that the card text
problem on my Power Mac G5 is fixed! Sure the text could look a bit
better, but there is text on the cards, and I am very happy. Thank you
for the hard work developing this mod and fixing this issue. Now, to
find opponents!

Could you post a screenshot?� I’m curious.

- M.

On 13 September 2010 01:13, Kingcake <matthewguidry@gmail.com> wrote:

I am the original poster of this thread. �I tried using the module with
the build of Vassal posted here and am happy to say that the card text
problem on my Power Mac G5 is fixed! �Sure the text could look a bit
better, but there is text on the cards, and I am very happy. �Thank you
for the hard work developing this mod and fixing this issue. �Now, to
find opponents!

Here’s the pic.

At least they look the same as on my computer now.

  • M.

On 13 September 2010 01:13, Kingcake matthewguidry@gmail.com wrote:

I am the original poster of this thread. I tried using the module with
the build of Vassal posted here and am happy to say that the card text
problem on my Power Mac G5 is fixed! Sure the text could look a bit
better, but there is text on the cards, and I am very happy. Thank you
for the hard work developing this mod and fixing this issue. Now, to
find opponents!

At least they look the same as on my computer now.

- M.

On 13 September 2010 01:13, Kingcake <matthewguidry@gmail.com> wrote:

I am the original poster of this thread. �I tried using the module with
the build of Vassal posted here and am happy to say that the card text
problem on my Power Mac G5 is fixed! �Sure the text could look a bit
better, but there is text on the cards, and I am very happy. �Thank you
for the hard work developing this mod and fixing this issue. �Now, to
find opponents!


I know this to be quite an old thread, but I think my issue fits quite well: I cannot see the card texts as well. I am running a Mac Book Pro Retina (2.3 GHz Intel Core i7) with OS X Mountain Lion 10.8.2. Furthermore, I am running Twilight Struggle Module 3.0.10a and tried it with Vassal 3.2.2 and Vassal 3.1.20 for Mac. I saw there is a checkbox for the mentioned Quartz setting and I tried it diabled and activated. Because of the available Quartz option I did not yet try the special build mentioned in this thread.

Thus spake snapped:

I know this to be quite an old thread, but I think my issue fits quite
well: I cannot see the card texts as well. I am running a Mac Book Pro
Retina (2.3 GHz Intel Core i7) with OS X Mountain Lion 10.8.2.
Furthermore, I am running Twilight Struggle Module 3.0.10a and tried it
with Vassal 3.2.2 and Vassal 3.1.20 for Mac. I saw there is a checkbox
for the mentioned Quartz setting and I tried it diabled and activated.

The problem doesn’t have to do with TS, but rather with the way Java
draws to Retina displays:

https://forum.vassalengine.org/t/missing-card-and-counter-text/5692/1


J.

Hi uckelman

Thank you for your quick response. I read through the whole thread. To sum up:

  • Java 7 should work. Java 6 doesn’t.
  • I should update to the lates Java 7 Version (oracle.com/technetwork/topic … 05892.html)
  • If I have Java 6 (from Apple) it will not be removed by the Oracle Java 7 Update. How to fix that (I might have to google that one)?
  • According to the latest posts there is still no solution, right? But there is a workaround (= update to Java 7), right?
  • In viewtopic.php?f=3&t=5974&start=60#p39111 you provide a new build for Vassal 3.2.2, but Twilight Struggle needs 3.1.x (I am using 3.1.20) to run. Is/Will there be a solution for 3.1.20 as well?

I am not a specialist with OSX terminal commands and java.Therefore I might understood things wrong. I appologies if I did so. Could you please let me know if I got it right?

Regards, snapped

Thus spake snapped:

[This message has been edited.]

Hi uckelman

Thank you for your quick response. I read through the whole thread. To
sum up:

I can’t say whether updating to Java 7 will solve the problem for
you. I haven’t heard from anyone else using Java 7 on a Mac with
a Retina display about whether they have the SVG rendering problem.
If you do upgrade to Java 7, we’d like to hear from you whether the
SVG rendering problem persists.

  • If I have Java 6 (from Apple) it will not be removed by the Oracle
    Java 7 Update. How to fix that (I might have to google that one)?

I don’t know.

  • According to the latest posts there is still no solution, right? But
    there is a workaround (= update to Java 7), right?

See above. I don’t know whether upgrading to Java 7 actually solves
the problem.

  • In viewtopic.php?f=3&t=5974&start=60#p39111[2] you provide a new build
    for Vassal 3.2.2, but Twilight Struggle needs 3.1.x (I am using 3.1.20)
    to run. Is/Will there be a solution for 3.1.20 as well?

No, there won’t be any future 3.1 releases.


J.

Thanks again for quick response.

Now I am confused. Isn’t Guillaume in your mentioned post saying, that SVG Text works with Java 1.7 (here viewtopic.php?f=3&t=5974&start=60#p38894).
I see no need in updating if it does not help.

I was told and read (https://forum.vassalengine.org/t/problem-with-twilight-struggle-in-v-3-2-2/5517/1) TS does not run with 3.2.2, but only with 3.1.20. In this case I got a problem, right?

Update conserning my system:
I updated to OS X 10.8.3 => problem still exists, but that is obvious.

Installed Java Version:
java version “1.6.0_43”
Java™ SE Runtime Environment (build 1.6.0_43-b01-447-11M4203)
Java HotSpot™ 64-Bit Server VM (build 20.14-b01-447, mixed mode)

Would you try a Java 7 update or shall I rather wait for progress on debugging?
Shall I move my topics to the other thread?

Thus spake snapped:

Thanks again for quick response.

I can’t say whether updating to Java 7 will solve the problem for
you. I haven’t heard from anyone else using Java 7 on a Mac with
a Retina display about whether they have the SVG rendering problem.
If you do upgrade to Java 7, we’d like to hear from you whether the
SVG rendering problem persists.

Now I am confused. Isn’t Guillaume in your mentioned post saying, that
SVG Text works with Java 1.7 (here
viewtopic.php?f=3&t=5974&start=45#p38755[1] and here
viewtopic.php?f=3&t=5974&start=60#p38894[2]).
I see no need in updating if it does not help.

He’s saying that the problem went away for him after updating to Java 7.
This isn’t sufficient evidence to say that the problem is fixed in Java
7. I would want more data before saying that.

No, there won’t be any future 3.1 releases.

I was told and read (viewtopic.php?f=3&t=5791[3]) TS does not run with
3.2.2, but only with 3.1.20. In this case I got a problem, right?

The TS maintainer is working on updating TS for V3.2. The current
version of TS is 3.1-only.

Would you try a Java 7 update or shall I rather wait for progress on
debugging?

If your goal is to run TS, then you can’t do that right now with 3.2.
Do you have the SVG rendering problem with 3.1.20?


J.

But it worked for him. I assume with 3.2.2 or your special build.

yes

Hi,
i’m running a imac with OS X 10.7.5 and for me the problem is:

  1. Running TS on VASSAL 3.2.X: I cant deal the cards… but i see the text all right (i know that TS is only for VASSAL 3.1.20 so this is not really a bug)…
  2. But when i run TS on VASSAL 3.1.20 i cant read the cards.

Ive updated to java 7 update 17 but both problems remain (i ended up with the complete JDK installation)…

Even more bizarre, i’ve managed to start a TS-game against other players using the 3.2.3 when my opponent used 3.1.20 and he set up the game (and thus were able to deal the cards) but then my opponent either cannot see his cards or cannot see the text (dunno exactly what happened)!!! But i find it strange that my opponent runs into trouble depending on my VASSAL installation (or whatever the problem is…).

Well, i dont know if this is any help to you so i wont spam the thread further…

Best regards…