Unable to take command, after connect to server

Hi All

I am playing GB II (OCS game) and that has been working. I then tested how to play by server, again no problems in that session. But now when I open the game I am unable to take commend, when I try I get:

has requested to join the Axis side

Same goes for Soviet side.
When opening my save file on another computer, I do not have this issue (also has not connected to server with that VASSAL).

How do I change back so I can continue my Game?.

Tech stuff
VASSAL version 3.1.2
Module OCS - Case Blue 4.1 (works on another PC)

Kind regards

I’m not quite sure I understand what is going wrong.

Are you saying that when you open an existing game in which you have already taken a Side, you no longer have access to that side?

Or when you start a new game, you cannot get access to a side?

Hi Brent

New game no problem, when I take command i do it as “newbie”. When opening my save game on PC1 I get “join Axis/Russian side”. In the text window it writes “has requested to join the Axis side”. On my PC2 I get Take Command and can play (same save file).

It seems that I miss the password for “newbie” under preferences!??!?!


I just tried to remove the module and imported it again, no change, still Join side request send:-(

Hi Henrik,
The OCS modules are not standard Vassal modules, they contain significant amounts of custom code. You will need to contact the maintainer of the module George Hayward (user george973) through the Case Blue module page to resolve this issue.

Hi Brent

Tried to write to George, but seems to bounce. But thanks.

It’s not entirely clear what’s happening. But I think you are saying that when you put it on the server you can’t join rom another PC.

Your identity in VASSAL is tied to your password. If you try and access
a game from a different machine which has a different password set for the game in its preferences VASSAL thinks you are a different person.

In normal modules you can only take control of a side if no other player has done so and can only control one side at a time. So if you use a different password you won’t be able to control the side you nwere playing

OCS modules have an expanded control system where it is possible to have more than one player per side. If you don’t command a side (your password doesn’t match someone who controls that side) you get the option to join a side. This posts a request which an existing player on that side must accept before you actually take control of the side.

If the OCS module gives you the option to join a side it means that it has registered at least one different password as controlling that side.
There will also be an option “Commanders of the X side…” which will show the names of the people currently in control of that side. If one of them is you then you’ve definitely a different password. Go into Preferences and select “Personal” tab and change the password to match the one you used initially.

If you don’t know what that was then you need to send me the save file so I can find out with the debugger.