User Experiences with Big Sur

Prompted by this note from PaulMcG on another thread, I installed Big Sur today on my MacBook. The previous Vassal 3.4.8 installation is running fine on it.

The only issue I had was that the Big Sur installer was giving me an error message part way through and stopping. I freed up a bit more disk space and rebooted; after that everything went smoothly.

I’m seeing an issue with several modules in my 2020 MacBook Pro, 16GB RAM. It seems that all displays and maps are placed as tabs in a single window, and I’m not able to successfully interact with any of them.The whole module becomes unresponsive as soon as additional tabs appear. Eventually the module icon will in the Dock will note that it is unresponsive, and provides the option to Force Quit.

I use multiple monitors and want to have separate windows to provide info. Even more than that, I want Vassal modules to function. Glad to provide any more detailed info if needed.

Your first port of call should probably be the VASSAL error log to see if any clues are in there.

Nothing much interesting in that log, but it is attached. If there is some debug mode which can be invoked at start time I can do that. I used VASL v6.6.1 as the test case here with engine v3.4.8. Removed and re-added VASL. Everything seems fine until another window is summoned, then the vmod is effectively dead.

Right, no obvious errors. Is it trying to re-tile images every time? I’m curious if nuking your tile cache would help. There’s no harm in it, all tiles will get recreated as needed when you open various modules.

No on tiling. I tried that to see if it made a difference, but the result is the same.

More context would help here.

  • Did the behavior change after you upgraded something? If so, what was upgraded? From what version to what version?

  • Would you post a screenshot of the problem?

Screenshot attached, though again it isn’t very helpful.You can see two tabs in the window where previously (in 10.15 Catalina) separate windows opened. Aside from this to me undesirable behavior, nothing in the window responds to my input afterwards – clicking on preference items in VASL, trying to select other tabs, etc. No workaround found, I have to Force Quit the module.

Glad to provide any further info. If there is a debug heavy incantation or build I can download and run to provide better logs, I’m glad to do that.

…and actually attached the screenshot this time. Also note that this is not limited to VASL for me. Three vmods tried all behaved the same. Using the former as an example due to it being so prevalent.


I don’t understand what you’re expecting to see here instead. How should it look?

I’ve been using Big Sur for a few games without problem but have just now experienced my first instance of the problem described above. I was using a 13" MacBook where previously I’ve been using a 27" iMac. Maybe this - screen size or keyboard - has something to do with it (more likely to have been using Full Screen).

The problem seems to be associated with opening additional module windows e.g. a hand window or to display a player aid. I am finding it difficult to work out exact steps to reproduce.

In my example, the hand window was displayed but appeared to be tabbed with the player aid window. As stated in the earlier report, the module itself seemed unresponsive from that point. I had to kill Vassal and restart. I was able to use the module normally in general.

I am wondering it some MacOS window-management feature might be in play here; a quick internet search perhaps confirms my suspicions: … g_as_tabs/
So, it looks like Big Sur likes to merge app windows and this can freeze the app. I have taken the advice in the Reddit article to turn “prefer tabs” to Never, in the General system preferences.


As Mark noted, this can be reproduced at least by myself by opening any additional windows aside from the original/main vmod. The tabbed display appears, and at least part of the new window/tab content. At that point the vmod stops responding to user input. I’ll try changing the Prefer Tabs preference later tonight to see if it makes a difference.

We don’t control whether those windows are grouped together as tabs. There is nothing we can set from within VASSAL to affect that. This sounds like a bug report to Apple is in order.

I have retested this on my Big Sur installation. Under the System Preferences > General panel, setting “Prefer tabs” to “Never” returned to the behavior under macOS Catalina, and the vmods I checked functioned properly.

I’ve seen quite a few reports of problems with Big Sur’s automatic tabbing with a wide range of applications. It looks like there will be fix for the tab label drawing problem in a Java update: … Order=desc

Thanks Joel - that problem you linked to is exactly what I have been seeing as the text in the title of the “Active” tab of a tabbed charts window, since moving to Big Sur. That particular one is not so bad as the tabs locking things up but nice to know it might get fixed.

Good Morning,

I am a new user to Vassal and installed this on a newly upgraded iMac 27 with Big Sur and had the exact same issues when selecting any option that opened another window within any module I loaded into Vassal. This resulted in a tabbed configuration view and a java instance that was unresponsive and could only be closed by a Force Quit option of the module.

Changing the General System Preference setting of ‘Prefer tabs’ from ‘Always’ to ‘Never’ resolved the issue and all tabs are now visible and the module continues to operate normally.

I have Windows 10 setup up in boot camp and testing of Vassal and several modules in that environment worked properly and the tabs are properly stacked in the additional windows that are created by the modules. When running on Big Sur, there is only a single row of tabs that you have to scroll through horizontally to get to them all.