v3.3.1-beta - behaviour of < and > in beanshell expressions

Is there something about v3.3.3 that would change the behaviour of the characters < and > ?

The following Beanshell expressions behave differently under v3.3.2 and v3.3.3-beta1 (and subsequent two v3.3.4 snapshots)…

Two examples demonstrate the problem:-

{ “<” + “this text does not appear in Report trait output under v3.3.3-beta1”}

{ “<” + “this text does not appear in Report trait output under v3.3.3-beta1 either, " + “>” + " but this text does”}


I would guess that has nothing to do with Beanshell, and everything to do with the new HTML support in Chatter. Try “<” instead of “<”.

Correct. If you have enabled HTML support, < and > are treated as parts of HTML tags and may not be displayed (especially <).

If you want to display a less-than sign, instead put: <
If you want to display a greater-than sign, instead put: >

By the way this is the specific reason that we needed to put the “enable HTML” setting – to avoid breaking prior modules that were naive to the new Chat Log.

Thank you both.


Could this be the cause of the other issue we though might have been the Game Refresher?

I don’t think it is this issue - my module doesn’t make that much use of <> outside of html. However, I think I have found a more concrete symptom that I hope will help shed some light. I have created a new thread.