Vassal 3.2.17 will not start

I need some expert help to get Vassal 3.2.17 to run on my machine. I am using Windows 10, and I have Java 8.0.2510.8.

Until recently, Vassal 3.2.17 has been working fine on my machine. The other day, I ran the disk cleanup utility on Bitdefender and after that 3.2.17 would no longer run. I would click the Vassal.exe or shortcut and nothing would happen. No error messages would appear; the program would not start then crash; nothing happens. I am sure I “cleaned” something important, so I tried uninstalling and reinstalling 3.2.17, but ended up with the same result. No activity of any kind. I am, however, able to run Vassal 3.3.2 just fine. Unfortunately, I need 3.2.17 to run one of the modules that I play regularly.

I am at a loss on what steps to take to try to get the program to run again, and I would gladly appreciate any advice or thoughts on what I can try to do to get the earlier version of Vassal to operate again.

Thank you in advance for your help.

Did you try reinstalling Java? And make sure your antivirus isn’t silently quarantining java.exe or javaw.exe, too.

Yup, that was it! Something went askew with Java, which had been fine since then. Thanks so much for the helpful pointer. Much appreciated : )