VASSAL-3.5.0-SNAPSHOT-db7ecdc7e strange behavior

OK, while testing VASSAL-3.5.0-SNAPSHOT-db7ecdc7e to see if it fixed another bug, I discovered some really strange behavior; the toolbar with the zoom controls is missing from many (but not all) of my windows. Then, while I had the module open for editing, I opened the definition for one of these windows (by double-clicking the [Map Window] entry), then closed it again with the Cancel button, which caused the window itself to also close, and now the button that is supposed to toggle the window open and closed does nothing…the window is permanently closed!

Ah, figured out why only some of them lost the toolbars; every window that’s defined as a [Map Window] has lost its toolbar and refuses to reopen after viewing the main properties; those defined as [Player Hand] or [Private Window] still work properly.

I have not gone back and tried in 3.5.0-beta 1, sorry.

There has always been an issue if you are editing and playing a module at the same time and try and edit a Map Component, then when you save the Map Edit, the map gets re-initialised, usually making it disappear. There is not much that can be done about this, except don’t edit maps while you are playing.

Can you reproduce the issue with the missing zoom controls?

Sorry for the delay in my response, but here you go:

Weird. I tried multiple versions of the Terraforming Mars module (2.8.3 is one I tried, available on the wiki page), and they all exhibit the same behavior (now using snapshot 56ed2625c)–any windows defined as [Map Window] are missing the toolbar, while those defined as [Private Window] or [Player Hand] are not. However, I tried another, much simpler module (Carcassonne: the Castle), and the toolbars appear just fine. C: tC has no private windows or player hands, so that might be the difference.

I also tried Merchant of Venus, and it, too, is just fine, but like C: tC, has no private windows or player hands.

Edit: Oops, that last is incorrect, MoV does have [Player Hand] windows; I was correct about it not having any [Private Window]s though.

I really should double-check things before I submit; as it turns out, Carcassonne: the Castle does have a couple of [Private Window]s after all (although those windows have no toolbars by design), but I was correct about it not having any [Player Hand] windows.

FYI, I’m on Linux (Kubuntu 20.10), but my friend on Windows 10 reports the same issue running 3.5 beta 1.

Bug filed at

Discovered one single [Map Window] was still showing its toolbar, and experimented with copying and deleting that window; see bug tracker for details.

This same behavior is still present in beta 2. Being unable to alter the zoom level of many windows is a bit of a deal-breaker; I won’t be switching to developing in 3.5 until this can be fixed, which is a pity, because a lot of the 3.5 features seem useful!

I’m trying to run this down now. It’s proving a huge pain.

Try VASSAL-3.5.0-SNAPSHOT-27a782b85:

A quick test seems to indicate the bug is fixed; all my toolbars are back in my current development version of the module, at least.

Thanks very much for tracking this one down!