Vassal 3.6.17 Released

VASSAL 3.6.17 Released

The VASSAL Team is happy to announce VASSAL 3.6.17.


  • NEW! 64-bit ARM packages: There are now MacOS and Windows packages for 64-bit ARM processors. If you have a Mac with an Apple Silicon CPU (which is a 64-bit ARM processor), we recommend using the 64-bit ARM build.
  • Code deprecated more than a year ago has been removed. Modules containing custom code using that code MUST be updated if they are to work with 3.6.
  • Things may be broken which worked previously. If you find a new bug, please report it.
  • Modules saved in 3.6 are not openable by earlier versions of VASSAL. We recommend keeping a backup copy of any pre-3.6 modules you plan to modify in 3.6 until you’ve verified that everything works to your satisfaction.


MacOS (64-bit ARM)
MacOS (64-bit x86)
Windows (64-bit ARM)
Windows (64-bit x86)
Windows (32-bit x86)

Changes since 3.6.16

Bug fixes

  • 12248: Don’t NPE when handling setup errors
  • 12247: Fix error dialog broken since 3.6.15 for exceptions with null messages
  • 12237: Fix edge case Mat Refresh bugs
  • 12234: Don’t try to render SVG which would have a width or height of zero
  • 12233: Ensure that OpMultiResolutionImage.getBaseImage() never returns null

Other improvements

  • 12250: Adjusted TilingHandler to simplify VASL and VSQL custom tilers
  • 12238: Upgrade bundled Java from 19 to 20

Changes since 3.6.15

Bug fixes

  • 12232: Notify user about mismatch between module and save version instead of throwing IllegalStateException
  • 12231: Check that all tiles exist for an image when tiling, not just 0,0@1:1
  • 12221: Fixed various missing searchability on various components
  • 12209: Report correct trait in expression Audit Trail
  • 12159: Correctly handle install paths containing spaces in
  • 12158: List Key Commands tool can be re-opened after closing with X button
  • 12152: Work around Java bug which prevents displaying Windows file dialogs

Changes since 3.6.14

Bug fixes

  • 12119: Restore vanished Load Comments
  • 12116: Pieces shouldn’t receive same GKC twice just because it sent them to a new map
  • 12105: Deck’s ‘Send-to-Deck’ subcomponent has access to properties (e.g., PlayerSide) and properly shuffles “always shuffle” decks
  • 12093: Fix disabling of toolbar items nested in multiple Toolbar Menus

Other improvements

  • 12140: Action Buttons on pieces that have just been drag-moved are suppressed for a half second for user-error avoidance
  • 12085: Screen capture default icon height adjusted to match the other 16-pixel-high icons
  • 12069: Tiling: Improved detection of and recovery from running out of memory; improved error dialogs
  • 9894: Improved error dialog for failure to start child process

See the Release Notes for descriptions of the changes in 3.6.

Minimum Requirements

VASSAL 3.6 requires Java 11 or later.

The Windows and MacOS packages have an appropriate version of Java bundled with them, so there is no need to install Java separately on those operating systems. On Linux, use your package manager to install Java 11 or later.

Help us test

Please report bugs in the Technical Support & Bugs category at the VASSAL forum.




Just wanted to say what a great job you guys are doing. I’m really enjoying all the new upgrades and features you guys have implemented to vassal. Thanks for the hard work!


I’m currently designing in V 3.6.7, having not updated for a year or so. Today I thought I would download the latest version (3.6.17?) to look at using it for future designs. However, after the download was apparently complete, I received a warning from Microsoft that the file “…isn’t commonly downloaded…” and I am prevented from placing the .exe file in my system for later installation (I don’t yet plan to design with 3.6.17 until I’m certain I don’t have any problems understanding it - I’ll continue to use 3.6.7). However, I can’t get to understand 3.6.17 if I can’t install it. Can you help, please?

There should be little to nothing new to understand for module design across patch releases. New features customarily don’t appear in patch releases. 3.6.17 shouldn’t affect your design work over 3.6.7 unless you were relying on a bug that we fixed. If you are relying on a bug we fixed, then discovering that is the first step toward correcting it, and the sooner the better.

This is your browser? Windows Defender? telling you that it hasn’t seen a lot of downloads of our installer yet—which is unsurprising, given that 3.6.17 was released only a week ago.

I’d like to be able to provide you with some screenshots of how to tell Windows that this is fine, but I’m not a Windows user so I can’t produce them myself. (If anyone can provide those screenshots, I’d appreciate having them.)

I think what you’re seeing is distinct from Windows Defender preventing the installer from running, for which we do have a FAQ entry and screenshots, here.

My guess is that you’re using Microsoft Edge for a browser–if that’s the case, it adds an extra layer of fussiness beyond what the Windows Defender feature does on its own. More information here, including a set of steps to circumvent it all.

If you use almost any other browser to download the current installer, I don’t think you’ll encounter this extra barrier, just the standard Defender warnings in the aforementioned wiki link.

This is very much a Microsoft Edge thing. I just tried downloading it myself and got the same message. All you need to do is click the meatball menu (three horizontal dots on the right side of the file), and click on keep. Then you will be able to open/run the file. Windows Defender may also throw a warning for you because the software isn’t “signed”, but you can just bypass that one as well.
Screenshot 2023-04-30 103655

1 Like

It was an Edge problem. Google Chrome solved it. Thanks, guys.