Vassal 3.7.9 Released

VASSAL 3.7.9 Released

The Vassal Team is happy to announce the release of Vassal 3.7.9.


  • There is now a single universal app bundle for MacOS. It runs natively on both 64-bit x86 (Intel) and 64-bit ARM (Apple Silicon) Macs.
  • Modules saved in 3.7 are not openable by earlier versions of Vassal. We recommend keeping a backup copy of any pre-3.7 modules you plan to modify in 3.7 until you’ve verified that everything works to your satisfaction.
  • Things may be broken which worked previously. If you find a new bug, please report it.


Windows (64-bit x86)
Windows (32-bit x86)
Windows (64-bit ARM)

Changes since 3.7.8

Bug fixes

  • 13176: Mouse-over viewer to respect Show Unrotated for Cargo on rotated Mats
  • 13166: Improved error catching and reporting when importing XML files into Editor
  • 13161: Prevent ArrayIndexOutOfBounds during search
  • 13152: Prevent NPE when cut/paste List Scenario Property
  • 13146: Game Piece Layer controls cannot be disabled by a property
  • 13132: Remove counters from Zone Count correctly when moving to Stack on another Map
  • 13130: Send to Location option should not appear in Preferences > General section of Reference Manual
  • 13126: SumRange function missing options in Expression Builder
  • 13115: Update Game Piece Layers updated correctly by Set Piece Property

Changes since 3.7.7

New features

  • 12898: Improved “Refresh Predefined Setups”: Expanded “orphan counter” functionality - reporting / ability to repair (sub-option); ability to do additional processing via a special post-refresh Global Hotkey, optionally without routine refresh reporting; new filter field and associated functionality for Predefined Setup Refresh; other UI improvements

Bug fixes

  • 13102: Current Location Fast Match was not recognizing pieces in same location but not same X, Y position
  • 13097: CountMap() by Property gives Bad Data error
  • 13087: Fix ‘Apply on Move’ description in Deck Send Key Command
  • 13083: Show Piece Property menu on Expression Builder trait fields
  • 13081: Sleep function now sleeps correct number of milliseconds instead of 2000
  • 13073: Attachments are lost after Undo
  • 13072: Cargo now correctly follows Mat after Moved Fixed Distance
  • 13057: Remove Unused Images does not find any images in use in an Extension
  • 13049: Compute correct _Degrees property for free rotations
  • 13040: Show correct sides in Wizard after using Prev button
  • 5813: Prevent Wizard crashing when using Prev/Next when no Password exists

Other improvements

  • 13119: Upgrade bundled Java to 21.0.2
  • 13101: Added Return to Deck to trait list in Reference Manual
  • 13092: Assorted documentation updates

Changes since 3.7.6

Bug fixes

  • 13022: Prevent room non-owners starting new games
  • 13021: Allow wizard to load setups from extensions
  • 13011: Spelling correction on Global Options panel
  • 13001: Fix poor performance of Piece Definer; remove spurious blank line from Mass Piece Loader
  • 12981: Fixed IndexOutOfBoundsException in empty chat room
  • 12971: Refresh visible portions of Maps after each UI, log, or network action
  • 12931: Prevent zero length string error on Deck refresh
  • 12894: Prevent crash if I/O Exception during CRC calculation
  • 12765: Cancelling Return To Deck no longer causes crash

Other improvements

  • 13037: Make Zoom component a default component of all maps
  • 13003: Do not record Map Id’s in saved Deck files so they will load on any Map
  • 12976: Search: Add option to exclude module elements when editing extension
  • 12768: “Player joins as side” message now broadcast to all players

See the Release Notes for descriptions of the changes in 3.7.

Minimum Requirements

VASSAL 3.7 requires Java 11 or later.

The Windows and MacOS packages have an appropriate version of Java bundled with them, so there is no need to install Java separately on those operating systems. On Linux, use your package manager to install Java 11 or later.

Help us test

Please report bugs in the Technical Support & Bugs category at the VASSAL forum.




I’ve downloaded the Win32bit version twice and the file is shown as “Unconfirmed xxxxxx.crdownload”.

Are you using Chrome? .crdownload is the extension it uses for partially downloaded files. If you have one of those, you don’t have a complete download.

(Also, you don’t want the 32-bit Windows version unless you’re actually running 32-bit Windows.)

Yes, Chrome.
I’m aware that crdownload typically means an incomplete download.
I didn’t have Java installed for the first two downloads. Installed Java and downloaded again - no joy, still crdownload.
As for 32-bit, dude, for how long have I been a pain in the ass around here? Years. :laughing: My computer’s old, 2008 vintage, from when Dubya was the prime criminal. It’s 32-bit.

So, three downloads now, all “Unconfirmed xxxxxx.crdownload”.

That will have no effect whatsoever on your download, nor do you need Java installed at all if you’re going to install Vassal from the Windows installer.

Is your AV program interfering with the download?

No indication that AV is interfering. Nevertheless, I turned it off temporarily, downloaded again, but still no joy. Still crdownload.

AV usually does some check during a Vassal install, but has never given me problems during the download itself. My last Vassal install was the previous version, 3.7.8, which downloaded and ran with no issues, just a few days ago.

Sorry, I don’t have any additional ideas. I use neither Chrome nor Windows myself.

You sure you got the correct versions on your end? Is the 32-bit download actually 32-bit? Didn’t get anything mixed up after a night on the town?
(Time for me to ask the dumb questions :laughing: )

I just tried to download the win32 file and had no issues at all. I would have to guess that you currently have a flaky connection to the github server where the download resides. If you’re using wireless, make sure you’ve got a solid signal. Otherwise, I would simply recommend you try again a bit later, and hopefully whatever part of the connection to github that is currently flaking out will be fixed.

Issue resolved. As usual it was a “user error”.

I warm-rebooted my computer. I don’t think this had any effect on anything, other than removing the previous “partial” downloads.

It did turn out that AV was interfering with the completion of the download, although I don’t know why it did that even after I turned it off. Note that I only turned off my “AVG Free”, not whatever Windows itself does in addition to that.
In any case, after telling it to ignore the perceived “threat”, the download completed normally, I installed Vassal and it seems to run fine.
I’ve never had this issue before with the actual donwload.

I did additionally notice one thing. The 32-bit file that downloads from the link below the front page header is still version 3.7.8, not the new 3.7.9. Only the 32-bit file that downloads from the News page is 3.7.9.

You need to reload the page.

IOW, you just fixed it. That was not a user error on my end.
I visit this site from a bookmark, and I’ve opened the front page several times this morning and up until a few minutes ago the file that downloaded from below the header was 3.7.8, not the new 3.7.9.

No, I changed nothing. You were seeing a stale, cached page until your browser re-requested the page.

OK, you’re the expert, good enough.
Out of curiosity, if my bookmark is “stale” why am I not seeing much older versions of Vassal when I click on the link below the header? Like, the version that existed when I created the bookmark months or years ago?

Bookmarks store a URL, not the contents of the page accessible via that URL.

This works as well as 3.7.8, meaning it crashes immediately upon opening every single time I try to use it. I’m running macOS Sonoma 14.1.

Also, for some time, after being forced out of a room and then re-entering, I find my previous self still present in the original room as well as the Main room.

You’re hitting a bug in MacOS 14.1. Upgrading to the current version, 14.3, seems to solve it: Known issue with Vassal 3.7.8 on M1 Macs? - #8 by JoelCFC25

1 Like

Thanks for the insight, Joel! I will give that a try. SO bizarre mine isn’t at the most recent version since I have it set for automatic DL and install…

Hi again Joel - that worked. Thank you!