Vassal Displays Wrong Module And Vassal Version Numbers

This is the first time posting here. But after careful consideration on my part, I think this is the right spot. It seems more technical than module-related in nature.

This is my problem. It may be nothing more than an annoyance but I’d like to know…

I launch Vassal, version 3.2.13 (I have ver 3.2.11 just in case). I click on “File” and “Open Module”. Open folder for module “1.7.1 - Base Game (without decks)”. (NOTE: This is important because I want to be able to add on extensions.) I click on “Arkham_Horror_FFG.vmod” and “Open”. A small window labeled “Processing Image Tiles” opens and performs its job. A much larger “Welcome” window opens offering three modes of play to choose from. I select “Start new game offline”, click on “Next”, choose Solo from the Drop-down list, and click on “Finish”. A 2-part window opens labeled “Arkham Horror controls”. The upper portion consists of the controls and the lower portion is the game board.

At this point there are two open windows pertaining to Vassal - one is labeled: “VASSAL” and the other is labeled: “Arkham Horror controls”.

Here’s my problem (Maybe it’s really only question?):

In the “Module Library” window, under “Module” it reads “Arkham Horror”. Under “Module Version” it reads “1.5.2” (I tried to load this module earlier to see if it would make a difference. It did not. I “Quit” the game and “Removed” the module. No difference.) Under"VASSAL Version" it reads: “3.1.14”. Under “Description” it reads: “Arkham Horror by FFG”.

Is this a problem? Am I worrying over nothing? Is this a minor bug? What’s going on here? I would greatly appreciate an explanation. Being more or less still a “newbie” of sorts I would like to know what is going on and whether I have something to be concerned about or not.

PC Info
Windows 7 Home Premium, Service Pack 1
64-bit OS
Vassal 3.2.13 installed at:
C:\Program Files (x86)\VASSAL\Vassal-3.2.13
Modules installed at:

Module: Arkham Horror
File Info
1.7.1 - Jan 10th 2013

      Base Game (without decks)

I’m still not clear precisely what the “problem” is. Are you saying that the module you downloaded is described as being version 1.7.1, but after opening it, it reports itself to be version 1.5.2? The column for “VASSAL Version” is just to indicate what version of VASSAL was used to create a particular module.

Just now I went and downloaded what purports to be version 1.7.1 of this module from here: … r_FFG.vmod

…but when I opened it up, it reports itself as version 1.6.9. This makes it look like the maintainers are either sloppy with their versions and how they edit the wiki for that module page, or they uploaded the wrong file. That is a question better posed directly to them. You need to be logged into the wiki to see email address information for any listed creators/maintainers.

Note that right-clicking and removing a module from the VASSAL Module Manager window does not remove any files from your PC–it merely takes the module out of the listing and removes any cached image tiles.

Thanks for your reply. :slight_smile:

You’re right about Vassal reporting it to be version 1.6.9. That is exactly what I got the FIRST time. Version 1.5.2 and 3.1.14 were from several tries later. Sorry. It was late. I was tired. Yadda. Yadda. Yadda.

My concern involved what version the module actually was vs. what it was reported to be. How did this affect playability with the numerous expansions for module 1.7.1. etc., etc.

In any case, I have taken the question to the module’s creators/maintainers as per your suggestion.

Thanks again,