Vassal doesn't start on my mac

Model: MacBook Pro
OS: masOS 10.14.2
Memory: 8GB
VASSAL: 3.2.17
Java: 11.0.2

I installed both Java and Vassal with Homebrew but when I try and start Vassal nothing happens. No error message, no icon in the Dock, and no Vassal process in Activity Monitor.

Where does Vassal store its log file on macOS?

Same here.
Upgraded to Mojave this morning, now Vassal won’t start anymore.
My laptop suggested downloading a Java Development Kit, but this didn’t do any good.
Help would be appreciated.

This keeps coming up, and shows no signs of getting better if people keep installing incompatible java versions.

The way to fix this (until vassal itself is updated) is to use an older version of Java. Since that’s not always an option for your entire system, you can download and install an older version of the JRE and put it wherever you like. You then need to modify the shell script that launches Vassal (inside to point to your custom JRE location.

Because no-one ever seems willing to do this, I’ve created a modifed DMG that includes an old version of the JRE (1.8.0_121). This is the last version of the JRE that still worked with the cmd-` shortcut properly, which is why I still use it specifically for Vassal.

Distributing this is probably against the agreement I had to pretend I read when I downloaded the old JRE, but since Oracle is inclined to keep introducting bugs, confusing users and developers with their version numbers, and ignoring compatibility: nuts to them.

You can download this modified version of Vassal here: … XOks_xchNb

I have not bothered to reproduce the nice appearance of the standard DMG, but the /Applications shortcut is still there so you can drag it to install.

What I have changed:
I added a folder under Contents/Resources called JRE. Under that is Oracle’s standard JRE distribution for the version mentioned above.
I modified the file Contents/MacOS/ so it only looks under this new JRE folder for the java executable.
Those are the only changes to the standard 3.2.17 you can download from I encourage anyone with the technical capacity to validate this for themselves and report back, because why should you trust me? I’m just some rando on the internet. I assure you I don’t have the time to try and exploit the five or so systems running Vassal on a Mac, but a little paranoia never hurt anyone.

If it turns out that bundling the JRE in this way causes a problem for anyone (or the forum mods know it’s a problem and want to remove the link), Vassal appears to still work with the Zulu JRE, which is GPLd. If necessary, I’ll make a new app with their 202 version. I’ve tested it briefly, but I’ll test it some more tonight with the modules I use.

per docs:

This does not seem to be the case, but for those who can downgrade, this works:

brew cask uninstall java
brew tap caskroom/versions
brew cask install java8

Yes, “5 or later” should probably read “5 through 8”.

I have the same issue. Mojave was ok but I made the mistake to install the new java version…I’ll try to install an old version of java…

I just made this account to say thank you for Malnorma. My Windows laptop broke and I had to use my gf’s Mac. Well, it was frustrating. I didn’t have a JDK etc…etc… finally I get it set up and it doesn’t open. Sad day. Your app worked. Thanks!

Thank you very much Malnorma! Your version is working perfectly fine for me!

Interesting… I have adoptopenjdk 1.8.0_242 installed via Homebrew. The Java executable is in /usr/bin/.

$ which java /usr/bin/java $ java -version openjdk version "1.8.0_242" OpenJDK Runtime Environment (AdoptOpenJDK)(build 1.8.0_242-b08) OpenJDK 64-Bit Server VM (AdoptOpenJDK)(build 25.242-b08, mixed mode)

I cannot start VASSAL by double-clicking the in the /Applications directory. But, I can launch from the terminal:

$ /Applications/

and the application starts right away.

Thus spake pixelpshr:

Interesting… I have adoptopenjdk 1.8.0_242 installed via Homebrew. The
Java executable is in /usr/bin/.

This won’t be an issue from 3.3.0 onwards, as we’re bundling Java with
VASSAL on Macs.

The release announcement for 3.3.0-beta2 is here: … -released/

This is a beta release, so not yet for general use.