Vassal Engine translation problem

Hello, I wanted to translate Vassal into a language not available in the app. When I run Vassal with the command “–translate” it displays an error window. After closing the error window, I have no texts, just empty fields. Where is the “.properties” file?

Please post the contents of the errorLog after you’ve had that message.

What language are you trying to translate?

I want to translate Vassal into Polish. I tested the translation functions some time ago on one of the earlier versions of Vassal. Everything worked fine then.

Error Log

2022-10-07 16:03:22,184 [10580-main] INFO VASSAL.launch.StartUp - Starting
2022-10-07 16:03:22,199 [10580-main] INFO VASSAL.launch.StartUp - OS Windows 10 10.0 amd64
2022-10-07 16:03:22,199 [10580-main] INFO VASSAL.launch.StartUp - Java version 18.0.1
2022-10-07 16:03:22,199 [10580-main] INFO VASSAL.launch.StartUp - Java home C:\Program Files\VASSAL-3.6.7\jre
2022-10-07 16:03:22,199 [10580-main] INFO VASSAL.launch.StartUp - VASSAL version 3.6.7
2022-10-07 16:03:22,438 [10580-AWT-EventQueue-0] INFO VASSAL.launch.ModuleManager - Manager
2022-10-07 16:04:46,583 [10580-AWT-EventQueue-0] INFO VASSAL.launch.ModuleManagerWindow - Exiting
2022-10-07 16:05:12,886 [8664-AWT-EventQueue-0] ERROR - not found
at VASSAL.i18n.VassalTranslation.(
at VASSAL.i18n.TranslateVassalWindow.(
at VASSAL.launch.ModuleManager.lambda$main$0(
at java.desktop/java.awt.event.InvocationEvent.dispatch(
at java.desktop/java.awt.EventQueue.dispatchEventImpl(
at java.desktop/java.awt.EventQueue$
at java.desktop/java.awt.EventQueue$
at java.base/
at java.base/$JavaSecurityAccessImpl.doIntersectionPrivilege(
at java.desktop/java.awt.EventQueue.dispatchEvent(
at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(
at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(
at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.desktop/java.awt.EventDispatchThread.pumpEvents(
at java.desktop/java.awt.EventDispatchThread.pumpEvents(
at java.desktop/

It looks like there’s some sort of path problem. We’re looking into it.

1 Like

Try the fix_i18n_path build from our development builds archive. Does that fix the problem for you?

Yes, it works! During the first test, I translated about 20 random lines of text, but only one line was saved in the file. On the second try, everything that I translated was saved in the file. As the translation progresses, I will check if it is a single incident or a line of translation that causes the problem.

Translation using the built-in module is almost complete. Some small error causes that the phrase “Quick Start”, even though it is translated by me, is displayed in English anyway.

Another thing is I can’t see lines from the module editor. Is it a bug or the editor elements can’t be translated?

There’s never been any facility for doing translations of the Editor keys, but you can translate them manually if you want.

The properties files are in vassal-app/src/main/resources/VASSAL/i18n/ in our repo. The English values for the Editor are in, and everything is otherwise parallel to the keys for Player and MM.

For Polish, you’d need to create an file.

Cool! I will translate the editor section and send it to the support email.

1 Like

I’ve made a pull request containing your Polish translation. Expect it to be in the 3.6.8 release in a day or two. Thanks!