Vassal Installation Troubleshooting 1o1

Hi folks,

it seems quite a few - independent of operating system - face the same issue.

Vasal 3.1.x to 3.2.x:


  • Have Java 8 installed
  • If you have Java 5/6/7 you can normally uninstall them safely (Backwards compatibility).
  • If you have Java 9 or later installed, check that your PRIMARY Java version is Java 8. (See below)

Where do you get Java from ?
Well the time only oracle supplied Java versions is over. So pick one.
In the spirit of free software try OpenJDK

What to pick from Java : JDK or JRE or Java Runtime Environment or Java Developer Kit
Well in the past there was a big distinction about the variants.
Modern Java would be by default the full Java Developer Kit (short JDK).

What that means is basically you get the Java Compiler on top of what you had in the Java Runtime Environment (short JRE).

Primary JDK ?
Well you can install multiple Java Versions, but one wins (by default) so you must make sure the right one wins.
This IS operation system specific.

Check current Java Version
Open a Terminal (xterm/fish on mac, cmd/powershell on windows, bash/sh/ksh/fish on linux)

Remember: You WANT Java 8.

So type in

java --version

You should see sth like this if you have Java 8 installed.

java version "1.8.0_241"
Java(TM) SE Runtime Environment (build 1.8.0_241-b07)
Java HotSpot(TM) 64-Bit Server VM (build 25.241-b07, mixed mode)

In case you have Java 9 or later installed (Here Java 14) you will get something like this

java version "14" 2020-03-17
Java(TM) SE Runtime Environment (build 14+36-1461)
Java HotSpot(TM) 64-Bit Server VM (build 14+36-1461, mixed mode, sharing)

in the same terminal as above type in the following command to list all installed Java Versions

/usr/libexec/java_home -V

Follow these instructions: … on-on-os-x

Note it makes sense to check a file named .bash_profile that is on your home directory for this value.

cat ~/.bash_profile

You may want to add the value there as well (but it may not be required depending on the exact OS X Version.

On Windows

  • If you used the Oracle JDK and its installer you have search for “Java Control Panel” to set things straight. Especially on Win 10.
  • If you used some “unpack zip” installer you have to set two Environment Variables one called PATH the other JAVA_HOME. Say you unpacked to C:\JAVA\java-8-jdk and there is also a folder C:\JAVA\java-8-jdk\bin then …
    [*] open your Explorer and right-click “This PC”, go to “Settings” (last entry)
  • On Win 10 (and maybe 8) there should be an Admin-marked “Change Settings” button on a fancy screen. Click it.
  • You’re on the System Properties dialgue
  • Switch to the Tab ‘Extended’ it provides you a screen with some text and 4 buttons the last labled ‘Environment Variables’ - Go there
  • Declare a new (USER) Variable called JAVA_HOME and set it to C:\JAVA\java-8-jdk (to match the example above)
  • There should be a (USER) Variable called PATH Add a new entry at the beginning “%JAVA_HOME%\bin”
    If you have Win 7 or older you may need to separate the entries ‘by hand’ using a Semicolon “;”

On Linux
Basically you have to do pretty much the same as on windows. Set JAVA_HOME and maybe extend your PATH.

whereis java

May help.

Also check the website of your linux distribution as there may be a rather simple way of doing so.
Gentoo →
OpenSuSE →
Redhat Linux (RHEL) → … t_JDK.html
Ubuntu → … va-version

@Ops : Maybe you wan’t to make this sticky