VASSAL Losing Connection to Server

Hello – I’ve done some searching of the forums for this topic and found some threads, but nothing so far that has helped get me any closer to a solution.

I have a windows 10 PC with VASSAL 3.2.16. When I join an online game, or start a room of my own, I will lose connection to the server after ~3-5 minutes of no activity in the module.

I understand that the problem is likely in my firewall/router/ISP. However, VASSAL is the only program that has this issue. I have experienced no other connection problems with any other internet connection on this system.

I have run tracert and ping to the VASSAL server, and the results are always good.

Given that, are there some resources that someone can point me to help troubleshoot this issue, most likely from a firewall / router configuration perspective? Is there a description of how the VASSAL connection to the server works that might help me understand why only the VASSAL connections are being dropped?

I have tried adding VASSAL and the java exe explicitly to the firewall on my PC, no luck. I am loathe to turn the firewall off entirely, but I suppose I could try that. I have also looked into my router settings and could not find any obvious tweaks to make to prevent a timeout.

I appreciate any help / resources folks can give me.

Ever got a solution direction for this problem?

Very interested because I suffer from same issue and would like to solve this.

Regards, John

I also have this problem and have searched the forums and have found nothing to help. And yet it seems to be happening to many of us.

Is there some kind of an activity timer involved?

Hi All,

I finally manage to ‘solve’ this issue.

I tested this problem at a friends home that uses the same internet provider and lives in the same area. Vassal was working fine here. Only delta was a different modem/router provided by the ISP.

Could still be home-network related, but I convinced my ISP to provide me with the newer model modem/router and my Vassal sessions are working just fine.

I still do not know the root cause of the problem (I really do know where to start) but I doubt that the modem/router (inherit firewall) settings where causing this problem. I spend some time digging into the old settings and could not see any surprising port-forwarding / blocking etc settings. Also all other applications, network , etc where working just fine.

This is the router that got replaced: Technicolor TC7210 swapped for: Connectbox (Arris TG2492LG).

Hope you all find some kind of solution because this is really a problem that kept me away from playing by Vassal.



Yesterday we tried “Battlestar Galactica” with Vassal. One of the players had intermittent connections issues (not only with Vassal, but with any other site), and reconnecting was tedious. We finally gave up.

I wonder whether Vassal is implementing any automatic re-connection and synchronization protocol. That would make the program much more robust and probably solve many of the problems listed in this thread.


Note for anyone seeing this later: As of 3.3.0, the client sends periodic keep-alive messages to the server, so disconnections due to inactivity should no longer happen.