VASSAL on a tablet (Android or Linux)

Good to see you got the terminal opened and that you can enter command on the command line (u0_a153@localhost: /$. Incidentally, u0_a153 is your user name, localhost is your machine name, and ‘/’ is your current directory). From the command prompt u0_a153@localhost: /$ you can see that your “current directory” is /. That is the root of the file system. You typically cannot write stuff here.

Go Home

Therefore, you should go to your “home directory”:

u0_a153@localhost: /$ cd
u0_a153@localhost: ~$

Above, I show how the command prompt will typically look after executing cd (which means “go home”). I will leave off the command prompt in the following.

In your home directory (~ which is really an alias for something like /home/u0_a153 or event /root), you typically have a directory (folder in Windows lingo) called Downloads. To see what files and directories you have in the current directory, do


(ls means list).

Find your download

Now change the directory to your Downloads directory

cd Downloads 

Your command prompt should change accordingly and look something like

u0_a153@localhost: ~/Downloads$

Now list the files and directories in the that directory


You should have something like VASSAL-3.2.17-linux.tar.bz2 there.

Extract VASSAL

You need to extract the content (unpack) that somewhere. Remember to type the file names exactly as shown. You can put it in your home directory with

tar -xzvf VASSAL-3.2.17-linux.tar.bz2 -C ~/

You will see a lot of print out on the screen of all the files being unpacked. Once that has completed, you can change directory to your newly unpacked VASSAL directory

cd ~/VASSAL-3.2.17

Your command prompt should once again change and show something like

    u0_a153@localhost: ~/VASSAL-3.2.17$

Check that you have Java installed

Before you go on, you need to check if you have Java installed. In your command prompt type


If you get a reply a la

-bash: java: command not found

then Java is not installed. If you get a long output with help text, then you do have Java installed and you can skip the next step. To install Java, do

apt-get install default-jre 

Now test that you have Java installed by repeating the test above.


Now that you have Java installed, you are good to launch VASSAL. First check that you are in the right directory


(Print Working Directory). It should report back something like


If not, then change directory to where you unpacked VASSAL

cd ~/VASSAL-3.2.17 

Now that you are in the installation directory of VASSAL, you can launch VASSAL. In the command prompt, type


Again, be sure to type the command exactly as given above. The . and / must be there and there cannot be any space between them and the V.

In case of problems

If any command in the above sequence does not work, then go back and double-check that you have typed the command right (you can use arrow-up to see previously entered commands). If you got it wrong, then try again. If you get a message like

VASSAL-3.2.17-linux.tar.bz2 Cannot open: No such file or directory  

then check that the file is actually there by using the ls command. If you get a message like

`execute`: command not found 

then double check that you’ve typed the command correctly and that it is one of the commands mentioned.

Do not go on in the process before you have corrected previous errors. If you get problems that you cannot solve, post a screen shot and detailed description.


The problem with this is that VASSAL 3.2.17 is so old that I don’t believe it will work properly with a modern version of Java. apt-get install default-jre is almost certainly going to get at least version 11 of Java, and 3.2.17 doesn’t work properly with anything later than version 8 (also known as 1.8) if I recall correctly.

3.2.17 won’t run with anything later than Java 8. This is one of the reasons I mentioned near the outset that it would be preferable to try installing the current version of Vassal.

saw some discussion about no java 7 or 8 for android 4. ubuntu is supposed to have 2 jre’s. tnx also for explaining what all that gibberish is in front of the little squiggle and the $ cursor. little sqiggle is shift 1st key next to the numbers top row. whats its name? tried some of the commands again see photo. can i downoad new vassal on android or need it be downloaded from linux? the tar extractor i picked requires android 5. suggest an oldie but goodie. want to experiment with what i got. suffice it to say i have never tried the internet from linux. tnx all.

Linux is case-sensitive. It is

cd Downloads 



Note, it looks like your Downloads folder is one more level down - try

cd sdcard 

You had

$ ls
Desktop    sdcard 
$ cd downloads 
bash: cd: downloads: No such file or directory 

From ls it is clear there’s no downloads folder in the current directory, so stop there and fix the problem. Then you go on

$ tar -xzvf vassal-3.2.17-linux.tar.bz2 
tar (child): vassal-3.2.17-linux.tar.bz2: Cannot open: No such file or directory 

Again, from the previous ls command output it is clear that the file vassal-3.2.17-linux.tar.bz2 does not exist in the current directory, so no reason to try the command which will fail.

Then you do

$ java 
bash: java: command not found 

but the apt-get install deault-jre above failed because you misspelled the command. No reason to test the since the previous commands failed.

Also, try

apt-get update 
apt-get install default-jre 

Please check your spelling - you had deault-jre. It is important that you type the commands exactly as given and if that fails, please double and triple check. If a command in the sequence fails, do not go on to the next one but fix the problem first.

As I said, if you see

No such file or directory

use ls to see if the you got the spelling or something wrong.


okay on the spelling. they used to sell a screen enlarger for phones and tabs. really need one. the terminal screen is hard to see. i bought something for a verizon droid 4 when u plug it in makes it like a lap top. like the droid4 but mine is hamstrung not having the sim enabled. but i am just musing. i want to extract the tar so i can see
what it looks like. ill try ubuntu on the motorola zoom if it really does have jre. even if the zoom is old hardware. tnx. also pulled out nortons guide to linux. was thrilled when the ls command was there. tnx.

You should be able to zoom in by “pinching-out” with two fingers. Alternatively you can choose a larger font size for the terminal.

I played around with my own phone a bit (a Moto Edge 20) and got everything working. I’ve put together a guide on how to do it and put it in the Wiki pages. However, it is awaiting moderation so I cannot link to it from here.

The short version of it is that all you need is

  • Termux
  • A VNC client (e.g., RealVNC)
  • and of course VASSAL

You can set-up a Linux Graphical User Interface (GUI) called “X” (no it has nothing to do with the service formally called “Twitter” even if that service has appropriated the name and logo of the “X” window system) in Termux. You can also install a Java Runtime Environment in Termux, which means that we can do all we want to do with Termux alone (AnLinux builds on top of Termux, but we don’t need that, and it seems to work better with just Termux).

Once the Wiki page has been approved (hey @uckelman or @Tim_M ), and can post a link to the page here. You can find the Wiki page here.

Below are screenshot of what it looks like

I think the Motorola Xoom is not a bad choice, even if the hardware is old.


Hi all,

The guide to run VASSAL on Android is now live. Find it here. Thanks to the mods for approving this.


1 Like

looks like ill have many a mispelling ops (HAHA).
going to be burning the midnight oil on this one. going to be great finally getting tech to do what i want.
tks tons RAy.

I recently got a Pine Tab 2 (Arm sbc linux tablet with Arch based KDE Plasma). It comes with a detachable keyboard/trackpad but I want to run in touchscreen mode. Linux support for touch devices is not as good as Android/iOS or even Windows. I have ran Vassal on an old Surface Pro 3 but the Pine Tab is lighter, no heat problems, and better battery life.

So I gave it a try and had unexpected problem in an unexpected area at the last hurdle. It runs fine except for the right hand menu that is pretty critical to use Vassal effectively.

The problem is getting touchscreen access to the right mouse button! Long press does not do anything. I don’t see anyway in Vassal to tweak. KDE Plasma uses Wayland not X for the windowing system which eliminates Touchegg.

Any ideas folks?

KDE Plasma works just fine with X; it certainly doesn’t require Wayland. This sounds like it could be one of the (many) situations where Wayland is still not “ready for prime time”.


Disclaimer: I do not use KDE, nor do I own a touch-screen device running KDE, so below is based on usual practise and what I can glean from the WWW.

I think KDE sets emulates right-click by a two-finger tap, or a tap in the lower right corner. Check the settings in the KDE settings app. Just to be clear, for a right-click, place cursor over piece, …, and then do a two-finger tap anywhere on the screen. Three-finger tap should give you a middle-button click.

It may not be a problem with Wayland but rather with KDE or Qt, or the driver for the touch-screen. PineTab’s are sort of a tinkering device, and perhaps its reasonable to expect some issues.