VASSAL on a tablet (Android or Linux)

This is a re-post of a discussion from another thread, so as to no hijack that thread.

Perhaps search XDA for more information on that device, and how to set-up Linux on that.

I’m not sure what you mean by “load”. Could you please elaborate on that? Please use a little time to make your questions, comments, etc. clear.

There are loads of apps that can unpack various compressed (or not) archives out there - both for Android and Linux. Perhaps you can be a bit more explicit about what it is you are trying to do.

The Motorola One Zoom should be able to run GNU/Linux natively - especially because it is not locked down. Another option is Motorola Xoom (10" tablet) which does have a bit older hardware.

Perhaps you could try to install DebianNoRoot on your device and see if you can get it working with that. DebianNoRoot does provide some mouse emulation and perhaps that is good enough for VASSAL.

For keyboards and mice I would get some Bluetooth devices - they will most likely work just fine.

Are you thinking about something like this? That won’t work for VASSAL as the Java Graphical User Interface (GUI) is not supported. A GUI needs to run in some graphical environment (X or Wayland on Un*x, Cocao on MacOSX, Win32 on Windows, Android UI for Android, etc.). The Android UI does not support the Java GUI (swing) as used by VASSAL.

This is why you most likely need a GNU/Linux virtual machine running on your Tablet or mobile device. Here, DebianNoRoot seems like a good solution. Of course, if you have a device to spare you can probably also get it to run GNU/Linux directly on the hardware. If you do get DebianNoRoot running you should

  • Open a terminal (see the linked article above)

    • Execute

      sudo apt install default-jre 
  • Download VASSAL Linux tar.bz2 from the virtual Linux machine

  • In your Linux virtual machine in a terminal

    tar -xjf VASSAL-3.7.9.linux.tar.bz2 -C ~/applications

and then follow the steps outlined in this thread

If I have the time, I might try this myself, but no promises :confused:


I installed Arch on a surface tablet and use it for Vassal, now I can play 40k anywhere

It works well on the Surface. Microsoft should stick to making hardware rather than software

ok it was a samsung 3 lite.
i had a tab that had lots of vassal dialog boxes. was looking for it but one had to be reset so maybe that was it. when i saw the vassal dialogs i thought i was getting close. so i must have unzipped the tar.
will any unzipper work with the tar?
i also once saw the command line. so if the load command is dimmed out can the unzipped tar be tried from the command line?
samsung version is 4.2.2. to cpt kirk thats a star date. vassal-3.2.17-linux.tar.bz2.
what is a vassal-3.2.17-linux.tar.1?
all the boxes look opened. downloaded several.

one caveat. make sure the tabs usb port is live.

the one on the sam 3 lite is charge only.
motorola zoom is not. i had seen a discussion on how to live it but was out of my ken.
im old school will have to print this out. need to be able to see several things at once.
where will i find the JRE if its on the tab? i think that might be the snick up. is where i think i got the debian.
touch padding with the linux open is sort of tedius. a 10 inch tab will be better.
i looked st the sd card and saw all but no vassal dialogs. had to have unzipped the tar once to even see them. if any unzipper will work will have to give it a go.
one more thing, might be reaching gor straws but in linux will the open command only work with linux files?? sometimes demos have something disabled. mostly save. anyway having installed linux on a tab for me is a success. getting vassal to run would be overjoyment.

Would you point me to whatever suggested that you download version 3.2.17 so I can correct it? The hasn’t been the current release since 2020.

You should use the current release—which is 3.7.9 as I type this—unless you have a specific reason for using an older release.

Hi Ray,

Please do consider to make your comments, questions, etc. easier to read. With that, it will be easier to understand what you mean and to give you appropriate comments. Thank you.

The relevant XDA forum

I’m not sure I understand what it is you are trying to accomplish or what your issue is.

Let’s take a step back.

  • One option is to install DebianNoRoot. Did you do that?

  • If you did, did you follow the video? It gives a number of pointers on how to use your newly installed Linux environment.

  • If so, do you understand how to open a terminal in the virtual Linux environment?

  • If so, did you manange to install the Java Runtime Environment?

    sudo apt install default-jre 
  • If so, did you open a browser in your virtual Linux environment and download the latest VASSAL distribution for Linux? You should find that in your Downloads folder. In a terminal do

    cd ~/Downloads 
  • If you did download VASSAL, did you uncompress and unpack it? In a terminal in your Linux environment

    tar -xjvf VASSAL-3.7.9-linux.tar.bz2 -C ~/

  • Then, did you manage to start VASSAL in your Linux environment? In terminal in your Linux environment

    cd ~/VASSAL-3.7.9

If you did all this, you can start to download VASSAL modules and open them using the VASSAL module manager.

No, only those that support TAR and BZip2.

Not sure what you mean by “dimmed out” and “be tried from the command line”?

Please elaborate - not sure what you mean. If it helps, you can take screenshots and append them your posts.

If you have Bluetooth Keyboards or Mice, then that should work too.

In a terminal in your Linux environment, do

dpkg -l default-jre

it should give a line that starts with ii if the package is installed.

Debian GNU/Linux is a full Linux distribution and does not reside on a sourceforge. DebianNoRoot is an Android app that sets up a virtual machine and installs Debian GNU/Linux in that virtual machine.

Clearly a larger screen (Galaxy 3Lite is 7") will be nicer. For the pointer, have you tried to pair your tablet with a Bluetooth mouse? I’m sure that will make the experience a lot nicer.

What do you mean by “vassal dialogs”? I’m not sure I understand the rest of the sentences either.

What do you mean by “open command”? What are you trying to do?

What do you mean by “linux files”? There’s no such thing as specific files for Linux.

Applications (or programs) are typically specific for operating systems and chip architectures. An application can be built for MacOSX on ARM but will not work on Intel, another application is built for Windows, but does not work on other system. But that’s the application - the data that the application works on is typically agnostic as to the system, though often specific for the application. Thus, typically, if an application runs on multiple systems (MacOSX, Windows, Linux, …), then the data can be worked on.

Point in question: VASSAL is a JAVA application, which is executed by a Java Virtual Machine (JVM - the Java Runtime Environment). As long as a JVM can run on a system, then it can in principle execute any JAVA application. In other words, the application that you download from VASSAL is the same for all systems, because it is really just data for the JVM.

More, so, the VASSAL modules (VMOD) are data to the VASSAL application and are independent of the executing platform (in fact, it is at least 2 levels of abstraction away from the underlying system) and are therefore not specific to any system.

I’m not sure that’s what you asked, though, so if that did not answer your question, please elaborate.

Yes, in the Evil world of non-open-source that is often the case. Not so in the OpenSource world that VASSAL and Linux are very much part of.

Try following the steps outlined above. If you have problems in any of the steps, try to describe exactly what it is you do, possibly taking screenshots, and then people may be able to help you out.

If you do get it working, I’m sure a description of the process would be very welcome in the VASSAL wiki pages.


it may be that long since i tried to vassal a tablet.
just reporting what i had on the tab.

ok. open command on my linux install is not highlighted so i cant load anything. all else is working. so if i unzip the tar i couldnt load it to run. why i asked about the unzip programs. i have not unzipped the tar. so what will it look like unzipped?
i found the 161 jpg vassal dialog boxes on the att tab. there are 1 linux installer there but wants root permission. not using that. an Anlinux installer. dont know where i got it but since it lists many distros must need to be online to install.
the vassal dilogs are the screens to load game parts. like picking side. counters. maps etc. when i saw these i thought i was on my way. but they are just the screens.
tks for all the info. tuesday ill try to get this thread printed out.
these 161 screens are on the att tab. a gpad f i think. its filled to the gunwales. i dont dare do anything until i transfer stuff to a card. i dont have linux installed but must have unzipped a tar to even see these.
later RAy.

this photo is of Debian file mgr. all tar boxes are open. i didnt unzip them with a tar unzipper. so what is it and where do i get it?
where do i view this video?
will be at the library today and will print this thread. hard using 2 machines at a time. need some hard copy to look at.
bare with me. succeeded in uploading the linux photo so thats a hooray for me.
later RAy.

If you double-click one of the files, does it open an application? If so, look for a command, button, menu-entry, … called something like Extract

Sorry, don’t get that. What do you mean by “jpg vassal dialog boxes”? Please elaborate.

In terms of permissions - are you perhaps trying to extract to some system destination like /?

Again, not clear what you are doing. Please elaborate.

Have you figured out how to open a terminal in your Linux virtual environment?

If so, have you tried running

cd /sdcard/Downloads 

and then

tar -xjvf VASSAL-3.2.17-linux.tar.bz2 

and then

cd VASSAL-3.2.17

and then


That should fire up VASSAL as per normal.

What do you mean by “open”? The icon may show an open box but that does not mean that you have “opened” the file.

You should remove all these .tar.bz2 files and download the latest and greatest VASSAL for Linux distribution. Then try to double click it. It will likely bring up a new window from where you can execute (button, menu entry) some Extract command. If no window is opened try following the procedure outlined above using a Terminal.

Follow the steps outlined above.

Which video? The one I referenced earlier - follow this link (click the blue text).

If you are having trouble finding the terminal, look for some sort of “Start menu” like button on the Desktop of your virtual Linux machine. Then click that and see if you can find “Terminal” in some menu (typically a sub-menu like “Utilities”). Then click that menu entry to open up the terminal application. In that terminal, type in the commands given above - line by line and executed by hitting Return.


i have opened a page that i call the command line. there are 2 terninal icons. 1 for rooted and 1 for not.
been there but didnt have any commands to enter.
will try the above suggestions before i try and download anything. i havent been able to get online with this tab since 2019 or so. all the linux stuff was 2017 18.
at the library one of the girls got it on line. i have to try it myself first.
why i want to try what i have first.
the icon boxes look like they are open but nothing is.
tks RAy.

ok watched the video. i have the Anlinux on the att tab. requires on line. video fills in some gaps.
tks agn. more later RAy.

okay find a photo o the screens or dialogs i found on the att tab.

From your screenshot it looks like you are viewing images (pictures - the app opened is Albums). This is not what you want.

Pick the one called Terminal or something like that (not the root version). What do you mean by “didnt have any commands to enter” ? You should see prompt, often something like one of


You then need to type in the commands (see previous posts) yourself. If an on-screen keyboard isn’t shown, use whatever means defined to get that opened. That is, in your terminal do something like

> cd ~ 

(that is, type c d [space] ~, followed by [enter]), and so on for the rest of the command listed in the previous posts.


this photo only shows 6. the other shows 161. i thought i was making progress but they are the screen and or dialogs for vassal.
ok got the bluetooth keyboard working. typed some stuff on the command line after a $ sign.
dpkg -1 default jre etc. debian came back with dpkg error unknown option -1. also listed good dpkg commands. then tried the tar. xjf vassal etc. said no such file found. thought i had the whole thread printed out but missed the cd entries. will hand scribe those. one parsing query. after the initial command is a space then the option then something like xjf should there have been a space before vassal etc?

dimmed open command.

sorry wrong photo. open command dimmed as forward is.

Commands should be typed exactly as given if you want them to work correctly.

dpkg -1 default-jre won’t work because the option is supposed to be a lowercase L, not a 1.

tar -xjvfVASSAL3.2.17-linux.tar.bz2 is missing a space between the options and the filename. This happens to work as expected because the f option requires a parameter following it—but if f didn’t require a parameter, omitting the space after the options would cause your whole filename to be interpreted as a sequence of options instead. However, tar failed anyway because the VASSAL3.2.17-linux.tar.bz2 isn’t in the present working directory.

tks. those lower case L’s always fool me. will try again. the cd command is what? change directory? so how do i get it to the right directory? i have to do the linux stuff at the table because of the keyboard. replying from the recliner. what is shhs or something like that in the An Linux file. if i try another linux install which one might come with the jre?

cd some_directory will change the current directory to some_directory.