VASSAL on macOS 14 Sonoma

Hi guys!

I’m a beta tester for the upcoming macOS 10.14 Sonoma. When trying to open Vassal it says it can’t be opened.
I can’t see any warnings in the Privacy & Security pane in System Preferences.

How is it with Java and Vassal these days? Do you need to have Java installed (I guess that it was deinstalled during the Sonoma installation)?

Any ideas?



You’ll probably have to be the canary in the coal mine and help discover what the issue is, because no one else here is likely to have access to MacOS beta versions.

VASSAL has for a few years now shipped with its own self-contained Java environment so users don’t have to download and install Java separately. At this time I think it’s version 20 of OpenJDK. Maybe some new feature in MacOS 14 is blocking that?

1 Like

Solved (somewhat)!

I had to open the shell java file from the terminal, and then it worked as intended. By some reason macOS doesn’t recognize the VASSAL Java package as an application file. Why, it’s over my payment grade.

So, for those of you that are in the same situation:

  • Be sure that Java is installed (it ain’t on some of the beta installations), download from
  • Be sure to download the latest Vassal version and place it in the macOS Applications folder.
  • Be sure that it has access (see here).
  • Start the Terminal, write /Applications/ and press return.

Play your favorite game. :smiley:

/from the coal mine :hatched_chick:

Is that an issue you can report to Apple as a Beta-tester ?

Do not do that. The version of Java you’re supposed to use is in the Vassal app bundle already.


You should report this problem to Apple and let us know what they tell you. Either it’s a bug they should fix, or there’s been some change with how app bundles should be structured of which they could make us aware.

Yep, I’ve already done that.

However, it’s not often that we get followups from Apple on reported issues. I will let you know when/if it’s resolved.


1 Like

I can tell that this issue is solved in Sonoma beta 4.



Mac OS blocks you from running any app that you downloaded from internet. Just use ‘Finder’ and then select ‘Application’ and select the apps that you have installed and tried to run.
And you can try to run the app from there.

Yes of course, but it wasn’t that this time. :slight_smile: