Vassal Performance on OS X 10.10

I upgraded to Yosemite last night. I installed vassal and Java JDK 8u25 x64 for Mac OS X. When I loaded the Fire in the Lake module, it runs reeeeeeally slow. Scrolling is choppy and lags. I don’t have any other apps running. It certainly wasn’t like is with Mavericks. The only things I can think of are either the new OS is sucking up more of my mac mini’s resources or there is some sort of problem with the Java performance. Any suggestions would be greatly appreciated.

  • John

I am having the same problem on a brand new MacBook Air. It is crazy. I am using the same java.

If you download the old Mac Java 6 runtime environment from the Apple site and just use that it will speed up for now.

Is this problem likely to ‘go away’ because Java is improved or is it likely to remain?

If the latter I think I’ll end up going back to Mavericks and Java 7.

I downloaded and installed Java 6 from here and it has solved the issues with scrolling and fonts - though I still have nagging worries about the security issues.

Thanks for the help. I’ve been busy the past couple days and forget to check back here. I tried downgrading to 7 but that didn’t do it either. I’ll try 6. I don’t remember which version I had on Mavericks. I’m not too concerned over security since I disable it’s use in Safari.

Apple’s Java 6 install by default disables the browser plugin, which is the source of all the security issues that have plagued Java.

Oddly enough, things didn’t work so I uninstalled Java 8, then I installed Java 6 and then installed the Java 8 plugin and everything still works fine.

I have manually disabled Java in Firefox and Safari - so hopefully I won’t encounter any problems.