Vassal text and icons very small on High Res screens

Like other java apps I suspect, using Vassal on a high res monitor on Windows, makes the icons and text very small. Changing the screen resolution just scales the app, with it appearing the same physical size, but now with muddier graphics, due to pixel scaling. I’m working on a Surface Pro 3, but a colleague has a 4k monitor, which makes things worse. Any ideas on how to get the app to honour the DPI, rather than scaling itself to the number of pixels?

Bumping the topic as I am having the same issue

This issue was raised before in another thread, with a suggested solution in this post:


(I haven’t tried this fix myself so I can’t vouch for its effectiveness.)

I too was having these issues, hope to try out said solution.

Me too… cant read the tiny text in popups on my monitor… worse as i have retinopathy and just dont see well

The posted solution has not worked for me :frowning:

This solution works in Windows 10.

Set the system font size too look good on your screen
Right click the Vassal.exe file select properties
Go to the compatibility tab
Check the box Override high DPI scaling behavior
In the drop down list Scaling performed by: Select System (not System(Extended) )

Vassal should now run with the system font size

Perfect fix pat-Thank you.