Vassal will not run

Before I attempted to replace a .png map image in my custom module I was able to run that custom module and several others.

After I could not replace the map image, I got someone from this forum to do that. He said to make sure my memory heap was set to 512, which I did. However, now Vassal will not load ANY module, this is after uninstalling and reinstalling Vassal, clearing the appdata folder, and clearing the image cache.

Attempting to import a module has Vassal declaring it is not a valid module for import. Attempting to open a module has Vassal just…sit there and do nothing. A check of memory shows that Vassal sits on under 50 MB memory usage while doing this.

Error log attached, and here is a dropbox link to my custom module. Any help on this would be greatly appreciated. … .vmod?dl=0

File → Import Module is only for importing sets originally created for Aide de Camp 2 (a competing and very old software product). It won’t help you here.

How much system RAM do you have? I was able to open the module on a Windows 10 system with 16 GB RAM and initial 256 MB heap / maximum 512.

That’s interesting you say VASSAL won’t open anything now. Does anything get written to the error log at all? I would’ve suggested deleting your VASSAL preferences (the V_Global file in the AppData folder), but you said you cleared that entire folder so that probably isn’t the problem.

So I downloaded and noticed that your map image is 18,900 x 16,692 pixels, which is quite extraordinarily large. I’d give strong consideration to splicing this into multiple images. For reference:

My system is a HP laptop running Windows 10 with 16 GB RAM as well. After resetting to 256/512 (from 512/768) I was able to open other modules again. Still no joy on my custom module however. I’m able to view the map image in every other program I open it with, just not as part of Vassal. The map image it replaces was only 2 MB smaller in size.

Further update. I cannot even load an older copy of the module to edit.

Additional edit. The problem seems to be that Vassal for some reason is not trying to tile any of the images in the module. Can anyone help me correct this?

Try deleting your tiles folder I guess? You’d find it in:


Tried that. Tiles folder was recreated however game still hung without showing any tiling progress. Please, is there some kind of setting or value I can check? Two people on this board have gotten the newer module to run, but not only can I not do that, I can’t get the OLDER module to run for some reason, even to edit it! I may have to rebuild from scratch and I don’t even know what the problem is!

It would help if you posted the contents of the errorLog from a failed attempt to tile.

However, an image which is 18900 x 16692 px will use be around 1204MB in memory just for the image data, and probably even more while image decoding is happening. My guess is that the tiler is throwing an OutOfMemoryError.

You’ll have better luck if you split that image into, say, a 6x6 grid of images instead.