vassal window doubles up

Hi guys.

For the last two months I keep on having recurring problems with Vassal, despite doing fresh installs.
The vassal window will “double up”. I will have multiple screens come up, and I have to hit the maximize button to “clear” it, but it just keeps happenning over and over again.
Eventually I have to save game, restart, and good for another 20 mins before it starts happenning again.
This is the only app or window I have issues with. Zero problems with all my other programs, its specific just to Vassal.

I am using the latest version of windows 10.
Any help would be appreciated.

Somewhere in the Preferences window should be an option to disable the Direct 3D pipeline; try that.

Ok clicked it, giving it a whirl…

Thanks jrwatts. Worked!